Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have the following problem.

A working verbose x11 forward request looks like this:

remote server release: Red Hat Linux release 6.2 (Zoot)

sh-4.1$  ssh -1 -vvv -l username -o "ForwardX11 yes" server.name netscape
OpenSSH_5.8p1, OpenSSL 0.9.8r 8 Feb 2011
debug2: ssh_connect: needpriv 0
debug1: Connecting to server.name [192.131.79.70] port 22.
debug1: Connection established.
debug1: identity file /home/username/.ssh/identity type 0
debug1: identity file /home/username/.ssh/identity-cert type -1
debug1: Remote protocol version 1.5, remote software version 1.2.26
debug1: no match: 1.2.26
debug1: Local version string SSH-1.5-OpenSSH_5.8
debug2: fd 3 setting O_NONBLOCK
debug1: Waiting for server public key.
debug1: Received server public key (768 bits) and host key (1024 bits).
debug1: Server host key: RSA1 0d:02:ad:64:5f:af:fa:e1:c6:ae:50:1a:91:7e:ab:f9
debug3: load_hostkeys: loading entries for host "server.name" from file "/home/shayre/.ssh/known_hosts"
debug2: key_type_from_name: unknown key type '1024'
debug3: key_read: missing keytype
debug3: load_hostkeys: found key type RSA1 in file /home/username/.ssh/known_hosts:1
debug3: load_hostkeys: loaded 1 keys
debug3: load_hostkeys: loading entries for host "192.131.79.70" from file "/home/shayre/.ssh/known_hosts"
debug2: key_type_from_name: unknown key type '1024'
debug3: key_read: missing keytype
debug3: load_hostkeys: found key type RSA1 in file /home/username/.ssh/known_hosts:1
debug3: load_hostkeys: loaded 1 keys
debug1: Host 'proxy-bt-2' is known and matches the RSA1 host key.
debug1: Found key in /home/username/.ssh/known_hosts:1
debug1: Encryption type: 3des
debug1: Sent encrypted session key.
debug2: cipher_init: set keylen (16 -> 32)
debug2: cipher_init: set keylen (16 -> 32)
debug1: Installing crc compensation attack detector.
debug1: Received encrypted confirmation.
debug1: Trying RSA authentication with key '/home/username/.ssh/identity'
debug1: Received RSA challenge from server.
Enter passphrase for RSA key '/home/username/.ssh/identity': 
debug1: Sending response to host key RSA challenge.
debug1: Remote: RSA authentication accepted.
debug1: RSA authentication accepted by server.
Authenticated to server.name ([192.131.79.70]:22).
debug2: x11_get_proto: /usr/bin/xauth -f /tmp/ssh-aPHVuHic3976/xauthfile generat
Warning: untrusted X11 forwarding setup failed: xauth key data not generated
Warning: No xauth data; using fake authentication data for X11 forwarding.
debug1: Requesting X11 forwarding with authentication spoofing.
debug2: fd 3 setting TCP_NODELAY
debug3: packet_set_tos: set IP_TOS 0x10
debug1: Sending command: netscape
debug1: Entering interactive session.
debug2: fd 0 setting O_NONBLOCK
debug1: fd 0 clearing O_NONBLOCK
debug1: Received X11 open request.
debug2: fd 4 setting O_NONBLOCK
debug3: fd 4 is O_NONBLOCK
debug1: channel 0: new [X11 connection from server.name port 1874]
debug2: client_check_window_change: changed
debug2: client_check_window_change: changed

the non working output is as follows:

Red Hat Linux release 9 (Shrike)


$ ssh -1 -vvv -l username -o "ForwardX11 yes" server.address netscape
OpenSSH_5.8p1, OpenSSL 0.9.8r 8 Feb 2011
debug2: ssh_connect: needpriv 0
debug1: Connecting to server.address [192.65.220.98] port 22.
debug1: Connection established.
debug1: identity file /home/username/.ssh/identity type 0
debug1: identity file /home/username/.ssh/identity-cert type -1
debug1: Remote protocol version 1.99, remote software version OpenSSH_3.7.1p2
debug1: match: OpenSSH_3.7.1p2 pat OpenSSH_3.*
debug1: Local version string SSH-1.5-OpenSSH_5.8
debug2: fd 3 setting O_NONBLOCK
debug1: Waiting for server public key.
debug1: Received server public key (768 bits) and host key (1024 bits).
debug1: Server host key: RSA1 53:40:10:d1:86:92:1e:d5:a1:70:0f:b0:4f:c8:67:eb
debug3: load_hostkeys: loading entries for host "ext-proxy-2.ftel.co.uk" from file "/home/shayre/.ssh/known_hosts"
debug2: key_type_from_name: unknown key type '1024'
debug3: key_read: missing keytype
debug3: load_hostkeys: found key type RSA1 in file /home/username/.ssh/known_hosts:1
debug3: load_hostkeys: loaded 1 keys
debug3: load_hostkeys: loading entries for host "192.65.220.98" from file "/home/shayre/.ssh/known_hosts"
debug2: key_type_from_name: unknown key type '1024'
debug3: key_read: missing keytype
debug3: load_hostkeys: found key type RSA1 in file /home/username/.ssh/known_hosts:1
debug3: load_hostkeys: loaded 1 keys
debug1: Host 'server.address' is known and matches the RSA1 host key.
debug1: Found key in /home/username/.ssh/known_hosts:1
debug1: Encryption type: 3des
debug1: Sent encrypted session key.
debug2: cipher_init: set keylen (16 -> 32)
debug2: cipher_init: set keylen (16 -> 32)
debug1: Installing crc compensation attack detector.
debug1: Received encrypted confirmation.
debug1: Trying RSA authentication with key '/home/username/.ssh/identity'
debug1: Received RSA challenge from server.
Enter passphrase for RSA key '/home/username/.ssh/identity': 
debug1: Sending response to host key RSA challenge.
debug1: Remote: RSA authentication accepted.
debug1: RSA authentication accepted by server.
Authenticated to server.address ([192.65.220.98]:22).
debug2: x11_get_proto: /usr/bin/xauth -f /tmp/ssh-kOywxfZB5752/xauthfile generate 127.0.0.1:0.0 MIT-MAGIC-COOKIE-1 untrusted timeout 1200 2>/dev/null
Warning: untrusted X11 forwarding setup failed: xauth key data not generated
Warning: No xauth data; using fake authentication data for X11 forwarding.
debug1: Requesting X11 forwarding with authentication spoofing.
debug2: fd 3 setting TCP_NODELAY
debug3: packet_set_tos: set IP_TOS 0x10
debug1: Sending command: netscape
debug1: Entering interactive session.
debug2: fd 0 setting O_NONBLOCK
debug1: fd 0 clearing O_NONBLOCK
bash: line 1: netscape: command not found
Transferred: sent 1096, received 716 bytes, in 0.0 seconds
Bytes per second: sent 26095.4, received 17047.7
debug1: Exit status 127

I can see my client machine is forwarding x11 traffic and I am able to establish a normal ssh session ok, just when I request the netscape from this particular release it fails?

the working release Red Hat Linux release 6.2 (Zoot) gives me:

debug1: Received X11 open request.

the non-working release Red Hat Linux release 9 (Shrike) exits with:

bash: line 1: netscape: command not found

apart from the obvious is there another browser supported on this release, and how can I get this to work?

share|improve this question
2  
You seriously still have netscape installed on all your machines? The 20th Century called, and they want their browser back. –  Paul Tomblin Dec 17 '11 at 16:56
    
haha not me mate work thing –  Tony Dec 17 '11 at 18:27
add comment

1 Answer 1

It's failing because it can't find a Netscape executable or wrapper script. Install Netscape or try Firefox.

share|improve this answer
    
bash: line 1: Firefox: command not found - how do I find out what browser I can retrieve is there a command on remote server? thanks –  Tony Dec 17 '11 at 18:25
    
Try opera and chrome. If none of them work it may not have a graphical browser installed. –  Kevin Dec 17 '11 at 19:25
    
Previous script we used was and this used to give me a browser, can't quite remember which one though.... ssh -1 -f -l $LOGNAME -o "ForwardX11 yes" -o "StrictHostKeyChecking no" -L 7011:1.1.1.1:22 proxy.server sleep 20 >/dev/null 2>&1 xterm -title ZEN -e ssh -q -o "StrictHostKeyChecking no" -2 -l username -p 7011 -L 8080:remoteserver.name:8080 localhost & –  Tony Dec 19 '11 at 20:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.