Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have an odd problem with suphp.

I have logged in as tom and added some php to a directory in my web server.

Now I'm getting this error:

Directory /home/.../web/public_html is not owned by tom

I can't/won't change the ownership of public_html as various different users may be contributing to the site in this way.

Is there a configuration in suphp I need to edit in order to allow this to work?

Thank you.

share|improve this question
    
note that if you are letting other users put php into a directory, where it will be run as user tom, you are letting them run arbitrary commands as tom already –  stew Dec 16 '11 at 20:22
    
As far as I can tell this is a design choice. I think it's stupid to have though. The single document root, along with no symlinks should make this unnecessary lists.marsching.com/pipermail/suphp/2008-April/001831.html –  puk Mar 5 '12 at 3:17
    
how did u solve this? –  Kshitiz Shankar Sep 5 at 12:11

2 Answers 2

suphp does not have such an option. AFAIK you have to solve it with real users and permissions.

share|improve this answer
chown root.root /

That command worked for me

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.