Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I installed the Nvidia driver on OpenSuse 12.1.

The driver was downloaded from http://en.opensuse.org/SDB:NVIDIA_drivers.

But after I installed the Nvidia driver, I cannot activate any desktop effects ("The following desktop effects could not be activated".) The whole graphic rendering is not optimal or not good. For example, if Dolphin is opening, you can see a small Dolphin icon jump. But during the animation the icon leaves a grey trail. Also if the window is moved, it starts to jitter.

Here is my xorg.conf

Section "Files"
    ModulePath   "/usr/lib64/xorg/modules/extensions/nvidia"
    ModulePath   "/usr/lib64/xorg/modules/drivers"
    ModulePath   "/usr/lib64/xorg/modules"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Samsung SyncMaster"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7600 GT"
    BusID          "PCI:5:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7600 GT"
    BusID          "PCI:5:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "DFP-0: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "DFP-1: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "On"
EndSection

Thank you.

share|improve this question
    
Keep in mind OpenSuse 12.1 is relatively new and this may well be a bug that will be ironed out in coming releases. I recommend you use the zypper to manage your driver download to make syre you get the right version for your card and make updates easier on yourself. Follow en.opensuse.org/SDB:NVIDIA_drivers –  MaxMackie Dec 13 '11 at 15:06
    
Thanks. Actually I did the mistake. I followed the site what you posted. I just totally forgot about it. But this issue is also from previous version of OpenSuse. And not just on this Linux distribution. But I tried all the solutions what i could find. But maybe you are right. And i need just to wait. :-( –  M.K. Dec 13 '11 at 15:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.