Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Every time I access the filesystem using:

  • :tabe dirname (e.g.: :tabe .)
  • :vsp dirname
  • :sp dirname

in order to open some file while editing another one, I lose the mouse support inside the Vim session.

I'm running Vim 7.3.346 inside a fresh install of Debian Wheezy, using xterm.

I've tested with the minimal settings for Vim, for example with this .vimrc:

set nocp
set showmatch
set ts=4
set shiftwidth=4
set expandtab
set foldmethod=syntax
syntax on
set autoindent
set smartindent
set mouse=a
set encoding=utf-8
set fileencoding=utf-8

Is there any solution, or a patch to a bug for this version of Vim?


Update: At work this problem has never happened, the computers and servers we have are:

  • Ubuntu 10.04.3, Vim 7.2.330
  • SUSE Linux Enterprise Server 11, Vim 7.2.108
  • Red Hat Enterprise Linux Server release 6.0, Vim 7.2.411

Should this be a problem of Vim 7.3?

share|improve this question
    
If you issue set mouse=a again after such a "breaking command", can you use the mouse again or is it permanently broken? –  bitmask Dec 9 '11 at 1:37
    
No, it keeps on working without any response to the mouse. –  nozimica Dec 9 '11 at 2:10

1 Answer 1

up vote 0 down vote accepted

If you are still using version 7.3.346, then I found an useful setting:

set ttymouse=xterm2

with it, I haven't had the problem at least for a relatively short time of testing.

This bug was reported, and should have been fixed with version 7.3.363-1.


UPDATE:

Debian Wheezy has upgraded its version of Vim to 7.3.363, and the problem seems to be solved.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.