Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

If I go to the front page of this site, and hit page down/page up repeatedly, it's pretty quick, and firefox-bin (iceweasel) uses maybe 50% CPU, Xorg uses maybe 40%.

If I go to Stackoverflow's main page instead, though, each page down/up takes ~1.1s, and Xorg pegs an entire core (almost 100%), but Iceweasel uses almost no CPU.

This only happens in Iceweasel (8.0-3). I have tested with a new profile (no difference). Chromium is fine. Konqueror (despite doing smooth scrolling!) is fine. Conkeror (which is based on XULRunner) also has the problem, but Iceape 2.0.14 (aka Mozilla Seamonkey) does not.

I've never noticed this on other machines, even when they're fairly similar software-wise (also nVidia, also Debian testing/unstable). Though the other one is much more powerful, so maybe I just don't notice it. (Edit: Checked closer, it pegs Xorg, just not for as long.)

I've put xtrace output of a page down on pastebin (at over 1300 lines, too long to inline here).

I'm just watching these top in an xterm. CPU is an Athlon 4400+ (dual core); 4G of RAM; machine is not thrashing, and there is no disk activity during test (confirmed by iostat -kx 10). Video card is a GeForce 7600 GT using the nVidia drivers (290.10-1). OS is Debian testing/unstable; xorg 1:7.6+9. Window manager is Enlightenment DR16. Compositing is not in use. TwinView is in use, with two 1600x1200 LCDs (both DVI). xorg.conf doesn't really have anything interesting—most everything is autoprobed.

How can I resolve this?

share|improve this question
1  
I've filed a Debian bug here: bugs.debian.org/cgi-bin/bugreport.cgi?bug=651490 –  derobert Dec 9 '11 at 3:41

1 Answer 1

up vote 2 down vote accepted

Firefox use a lot of xorg resources (much more than other browsers). But I think your problem may be related to hardware acceleration.

  • Open Iceweasel and disable this option:

firefox

  • Exit of Iceweasel and look in top if this is closed.
  • Run Iceweasel and try again the websites.

Next steps:

  • If the problem persist, try with the official version of Firefox.
  • If the problem persist with the official version, report to Mozilla.
  • If the problem only occur with Iceweasel, report to Debian.
share|improve this answer
1  
I tried turning off the hardware acceleration option, it made no difference. However, once I finally found upstream's x86_64 builds (which they do their best to hide, for some reason), the problem doesn't happen with Firefox—only Iceweasel. –  derobert Dec 9 '11 at 1:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.