Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently I bought me a Linksys e3000 access point. I configured this access point to, on 2.4GHz, only allow connections with 802.1n. The laptop I use has a Altheros AR9285 wifi chipset.

Connecting works fine but the connection speed is not what I would expect. The distance between me and the access point is 2 meters with nothing in between.

When downloading from a host behind the e3000 serving a file from a ramdisk (400MB) to a ramdisk on my laptop, I get 1544.9 kB/s. A pc which is connected using a wire reaches 27330.2 kB/s, which is considerably faster.

So I did a iwlist wlan0 scan and this is what I got:

                Quality=65/70  Signal level=-45 dBm  
                Encryption key:on
                Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                          24 Mb/s; 36 Mb/s; 54 Mb/s
                Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s

What is going on here? The AP tells me in its webinterface that it is capable of doing 150Mb/s. Also with my wi-spy I verified that nothing else is using the spectrum of the configured channel.

Anyone got an idea how to fix this?

share|improve this question
up vote 1 down vote accepted

Your Client uses the Altheros AR9285 wifi chipset that transmits a single stream. Your Linksys e3000 uses Broadcom BCM4716 chip rev 1 pkg that transmits 2 streams Your client has no ability to take advantage of the 2 streams so it dumbs down to the lowest common denominators which is eactly what you are getting.

share|improve this answer

I also have an Cisco E3000 router and the same Atheros WiFi chip in my laptop running Debian 8, you must change a few settings on your router and you will get 150Mbps as I am.

Use 5Ghz and make the channels 40 Mbps wide and save (basic wireless page). Then I also set network mode to: "Wireless-N Only" Turn off CTS Protection Mode: and make beacon intervals 75.

Reboot the router and your laptop and you should be good to go.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.