Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have Debian Wheezy installed with the latest XFCE desktop environment. In the XFCE settings, I specified that external media be automounted upon insertion.

However, when I plug in my USB stick, it appears on my desktop, but is not mounted because there is no permission. In fact I have to use sudo to mount, access, read, and write from the USB drive.

I don't want to use the fstab method because you need an entry for each unique device and it is simply very inefficient.

How can I setup my system so that whenever I plug in an external storage device, it will automount and be fully user accessible? It seems a little silly that this functionality does not come "out of the box" and "just work" (or at least easily enabled) in the 21st century... :)

Thanks for your help!

share|improve this question
    
what Login Manager are you using (slim, gdm, xdm ...)? –  Hanan N. Dec 4 '11 at 5:40
add comment

3 Answers

make sure that the following packages are installed:

gvfs and thunar-volman

and make sure that at your ~/.xinitrc file, there is aline like exec ck-launch-session startxfce4 (it normally the last line at that file),

and you make sure that you are member of the plugdev group with the id command with the regular user, in case you aren't add your user to it with useradd -G plugdev username.

if you need more details see here.

share|improve this answer
add comment

Could try usbmount. This question is probably a dupe. Please read instructions there.

share|improve this answer
add comment

Afaik you need to add your user to the group plugdev.

In console:

sudo adduser <yourusername> plugdev
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.