Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am using pinguyos 11.10. Pinguyos is a variant of Ubuntu 11.10.

I have installed zram like this:

sudo add-apt-repository ppa:shnatsel/zram
sudo apt-get update
sudo apt-get install zramswap-enabler

But zram doesnot start automatically upon startup. I have to manually say: service zramswap start to make it start. Before and after enabling zramswap manually free gives this:

Before:

             total       used       free     shared    buffers     cached
Mem:       2061184    1165240     895944          0      31632     559816
-/+ buffers/cache:     573792    1487392
Swap:            0          0          0

After:

             total       used       free     shared    buffers     cached
Mem:       2061184    1217888     843296          0      33136     567232
-/+ buffers/cache:     617520    1443664
Swap:      2061176          0    2061176

And I have no physical swap partitions enabled.. so does this make any difference? Is a swap partition necessary for zramswap to work?

P.S Until I start the service manually, there is no zram0,zram1 in /dev Thanks for any help in advance.

share|improve this question

migrated from askubuntu.com Dec 3 '11 at 12:51

This question came from our site for Ubuntu users and developers.

    
Pinguyos is not an offical Ubuntu derivative, so therefore your question does not belong on Ask Ubuntu. It should be moved to the Unix and Linux StackExchange, which is accessible through Unix.stackexchange.com. –  William Dec 1 '11 at 4:38

1 Answer 1

up vote 1 down vote accepted

Run sudo gedit /etc/init.d/rc.local and modify the file to contain your service zramswap start command. This should run the command at the end of the boot process.

share|improve this answer
    
Thanks, after adding the service zramswap start to rc.local.. it worked.. :) but still wondering why the script from ppa didnt do this first hand?? –  ashishsony Dec 1 '11 at 15:52
    
I'm not sure, did you do what was specified in this link? If you did, it should have worked, but it may have had a bug or something. –  Dalton Miller Dec 1 '11 at 16:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.