Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

I want to shutdown my X to be able to install proprietary NVidia driver, but I couldn't find out how. There are some suggestions that didn't work for me.

I neither have /etc/init.d/gdm nor /etc/init.d/kdm nor /etc/init.d/xdm, on which I could call stop or start.

/etc/init.d/x11-common commands seem to have no effect, neither does init 2.

What can I try next?

share|improve this question

2 Answers 2

up vote 7 down vote accepted

Xubuntu uses upstart, so you should use

sudo service gdm stop


sudo service lightdm stop

depending if you are using Ubuntu 11.04 (or prior) or Ubuntu 11.10.

share|improve this answer
thx! service lightdm stop does its job for me :) I know why I prefer stackexchange over ubuntuforums ;) – Rafael T Dec 3 '11 at 12:59

check /etc/inittab and see if X is getting respawned everytime?. BTW, I would usually go to init 3 myself to shutdown X and perform any X related configuration. You can alternatively try to login into the other terminals provided with Ctrl + Alt + F2 or F3 and make the changes in there rather while X is shutdown using init 3

Ubuntu uses upstart so Xubuntu might as well be. I tried looking elsewhere for this ..

share|improve this answer
init 3 seems to have no effect. So if I go to tty2 as root and enter init 3 nothing happens. I have on ctrl+alt+f7` the same xfce screen with windos open than before. I don't have /etc/inittab either to look at – Rafael T Dec 3 '11 at 12:38
/etc/inittab does not exist, you meant? sounds strange to me. Ubuntu uses upstart so Xubuntu might as well be. I tried looking elsewhere for this .. – Nikhil Mulley Dec 3 '11 at 12:45
Use update-rc.d to disable the gdm service and try a reboot. Perhaps it can take you to the text logins. – Nikhil Mulley Dec 3 '11 at 12:46
yes, /etc/inittab does not exist. – Rafael T Dec 3 '11 at 12:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.