Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have an Ubuntu server that connects to the network over wireless. Since it obviously doesn't have Gnome's NetworkManager I have to configure everthing manually.

I've got it sucessfully connecting to the network but when the connection gets interupted instead of roaming to a different WAP it just disconnects. This is obviously bad but I have no idea how to make it roam.

Self-Help thorugh googling has been difficult since no one does this (for good reasons), everything I've found has been for a full desktop, not a server. While I'm totally against installing Gnome, I would prefer not to.

Is there any "command line" equivelent to NetworkManager that roams WAPs when the one its connected to times out?

Note: I'm not interested in "Do not use wireless" answers. I would normally never do this but this is a unique case. Just please answer the given question

share|improve this question
    
+1. I am also looking for the answer or direction. I use ratpoison as window manager and do not use any full furnished desktop. So I am also facing the same issue. –  Sachin Divekar Dec 2 '11 at 19:25
    
We've had a few questions about command line alternatives to NM: All commands that should be used to connect to wifi in command line Command line join of password protected wireless networks in Ubuntu, Arch Linux, or other distros? and more. I don't know how they handle roaming. –  Gilles Dec 2 '11 at 23:26
add comment

1 Answer

up vote 0 down vote accepted

For others reference, I found that wpa_supplicant was the best (only?) option. Took a while to configure it but it worked.

The only issue that prevented me from using and eventually scrapping the project was due to my unique situation: I needed to change the MAC address. Apparently wpa_supplicant completely ignores a spoofed MAC address.

Since 99% of people don't care about spoofing MAC addresses, wpa_supplicant works.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.