Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Is there a program in the official Scientific Linux repositories that can communicate with people over Skype? I'm worried about Skype's security, but I want to be able to log in to my Skype account and call/chat with my Skype friends.

share|improve this question
    
I know it is not an answer, but is not skype secured? Skype installation key not imported does not mean that skype protocol communication is insecure. –  Nikhil Mulley Dec 2 '11 at 19:31
1  
The problem is I can't get the GPG key for Skype. So if I configure the Skype repository, I can't get updates safely, that's the only problem.. gratz microsoft.. :\ –  LanceBaynes Dec 2 '11 at 20:13
1  

2 Answers 2

Try this method.

  • Import or Download GPG Key from here .
  • Download the GPG key and then export it to the expected place as root user:

gpg --keyserver pgp.mit.edu --recv-keys 0xD66B746E; gpg -a -o /etc/pki/rpm-gpg/RPM-GPG-KEY-skype --export 0xD66B746E; sudo rpm --import RPM-GPG-KEY-skype;

  • Add or Update the following repo file int the /etc/yum.repos.d/skype.repo

[skype]     
name=Skype Repository     
baseurl=http://download.skype.com/linux/repos/fedora/updates/i586/     
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-skype 
enabled=1    
gpgcheck=1

  • Download & Install Skype

    wget http://www.skype.com/go/getskype-linux-beta-fc10

    • Install the other libraries that might be needed for skype to work

      sudo yum install also-lib also-plugins-pulseaudio dbus-libs e2fsprogs-libs expat fontconfig freetype glib2 glibc keyutils krb5-libs libpcap libgcc libICE libpng libselinux libSM libstdc++ libX11 libXau libxcb libXcursor libXdmcp libXert libXfixes libXi libXinerma libXrandr libXrender libXScrnSaver libXv openssl qt qt-X11 zlib

      sudo yum localinstall skype-*.rpm

      • If it does not work still, then try sudo yum localinstall skype-*.rpm --nogpgcheck
  • It seems the installed version needs some ld_preload hack to get executed. Update this in your ~/.bashrc.

    alias skype='LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype'

share|improve this answer
    
Let me know if it did help? –  Nikhil Mulley Dec 3 '11 at 12:50
    
After "yum install skype": Package skype-2.1.0.81-fc.i586.rpm is not signed –  LanceBaynes Dec 4 '11 at 2:03
    
Did you actually run rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-skype after you have done download the key file? –  Nikhil Mulley Dec 4 '11 at 17:15
    
well, I would rather check the package is in its integrity with -K option. If I am sure that I have downloaded the rpm package from the right source of the website then I would go ahead and install away the package by passing the gpg check with yum install --nogpgcheck skype or disable the gpgcheck in the repo configuration file and proceed with installation. –  Nikhil Mulley Dec 4 '11 at 17:25

If you are looking for third party applications as in, API then Skype does offer APIs for many programming languages including perl. I am sure you can search through some of the Skype APIs for C++, Perl(Net::DBUS::Skype), Python that can offer you the same functionality of the skype interface for later wrapping in the applications. Cheers.

share|improve this answer
1  
There are other methods if you do not want to install Skype on the system due to various reasons (insufficient privileges, insufficient disk space, memory constraints etc.,.) then choose third party web interfaces for Skype. Websites like imo.im and plus.im offer that functionality, however the trust is what you have to weigh in to use them. –  Nikhil Mulley Dec 4 '11 at 12:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.