Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed CentOS6 and it is the first time. I tried to install/update packages. But I coudn't. Here is the output and it doesn't stop. How can I solve this?

[root@localhost suranga]# yum update
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * base: mirror.nus.edu.sg
 * extras: mirror.nus.edu.sg
 * updates: mirror.nus.edu.sg
base                                                     | 3.7 kB     00:00     
http: //mirror.nus.edu.sg/centos/6.0/os/i386/repodata/2b014e1fcde80ec1cc69d6a048f260f712b1ae2d83d1fc04d3b3c00ade817ec9-primary.sqlite.bz2: [Errno 12] Timeout on http: //mirror.nus.edu.sg/centos/6.0/os/i386/repodata/2b014e1fcde80ec1cc69d6a048f260f712b1ae2d83d1fc04d3b3c00ade817ec9-primary.sqlite.bz2: (28, '')
Trying other mirror.
http: //centosmirror.go4hosting.in/centos/6.0/os/i386/repodata/2b014e1fcde80ec1cc69d6a048f260f712b1ae2d83d1fc04d3b3c00ade817ec9-primary.sqlite.bz2: [Errno 12] Timeout on http: //centosmirror.go4hosting.in/centos/6.0/os/i386/repodata/2b014e1fcde80ec1cc69d6a048f260f712b1ae2d83d1fc04d3b3c00ade817ec9-primary.sqlite.bz2: (28, '')
Trying other mirror.
http: //mirrors.ispros.com.bd/centos/6.0/os/i386/repodata/2b014e1fcde80ec1cc69d6a048f260f712b1ae2d83d1fc04d3b3c00ade817ec9-primary.sqlite.bz2: [Errno 12] Timeout on http: //mirrors.ispros.com.bd/centos/6.0/os/i386/repodata/2b014e1fcde80ec1cc69d6a048f260f712b1ae2d83d1fc04d3b3c00ade817ec9-primary.sqlite.bz2: (28, '')
Trying other mirror.
http: //mirror.vietoss.com/CentOS/6.0/os/i386/repodata/2b014e1fcde80ec1cc69d6a048f260f712b1ae2d83d1fc04d3b3c00ade817ec9-primary.sqlite.bz2: [Errno 12] Timeout on http: //mirror.vietoss.com/CentOS/6.0/os/i386/repodata/2b014e1fcde80ec1cc69d6a048f260f712b1ae2d83d1fc04d3b3c00ade817ec9-primary.sqlite.bz2: (28, '')
Trying other mirror.
http: //centos.vr-zone.com/6.0/os/i386/repodata/2b014e1fcde80ec1cc69d6a048f260f712b1ae2d83d1fc04d3b3c00ade817ec9-primary.sqlite.bz2: [Errno 12] Timeout on http: //centos.vr-zone.com/6.0/os/i386/repodata/2b014e1fcde80ec1cc69d6a048f260f712b1ae2d83d1fc04d3b3c00ade817ec9-primary.sqlite.bz2: (28, '')
Trying other mirror.
http: //ftp.cuhk.edu.hk/pub/Linux/centos/6.0/os/i386/repodata/2b014e1fcde80ec1cc69d6a048f260f712b1ae2d83d1fc04d3b3c00ade817ec9-primary.sqlite.bz2: [Errno 12] Timeout on http: //ftp.cuhk.edu.hk/pub/Linux/centos/6.0/os/i386/repodata/2b014e1fcde80ec1cc69d6a048f260f712b1ae2d83d1fc04d3b3c00ade817ec9-primary.sqlite.bz2: (28, '')
Trying other mirror.
http: //mirror-fpt-telecom.fpt.net/centos/6.0/os/i386/repodata/2b014e1fcde80ec1cc69d6a048f260f712b1ae2d83d1fc04d3b3c00ade817ec9-primary.sqlite.bz2: [Errno 12] Timeout on http: //mirror-fpt-telecom.fpt.net/centos/6.0/os/i386/repodata/2b014e1fcde80ec1cc69d6a048f260f712b1ae2d83d1fc04d3b3c00ade817ec9-primary.sqlite.bz2: (28, '')
Trying other mirror.
share|improve this question

The URL's you're seeing are just URL's that you need to be able to pull up on your browser, and traverse. I grabbed the first URL and started going down the chain until I got to http://mirror.nus.edu.sg/centos/6.0/. Therein was a readme file containing this

This directory (and version of CentOS) is depreciated. For normal users, you should use /6/ and not /6.0/ in your path. Please see this FAQ concerning the CentOS release scheme:


If you know what you are doing, and absolutely want to remain at the 6.0 level, go to http://vault.centos.org/ for packages. Please keep in mind that 6.0 no longer gets any updates

So it looks like you've got an outdated repo list. Edit your repos (/etc/yum.repos.d/) and change the 6.0 to 6. Then take those URL's and traverse them to see if they'll take you to the right place. If not, search the web for an updated repo list.

CentOS points the centos/6 directory to whatever the newest point release is. 6.1 is just considered a patched version of 6.0, and what they consider "6".

share|improve this answer
$ sudo yum clean all

$ sudo yum update

Repeat 2 times if needed.

share|improve this answer
Welcome to StackExchange. Here is a little secret to getting a badge - go to this link and read the page unix.stackexchange.com/about. – Devyn Collier Johnson Jul 9 '13 at 12:46

There's some problem with your network settings and/or connection. Try to (re)configure network interface. As a first step you might want to run 'netstat -i -e' to list interfaces and make sure they've assigned correct ip addresses.

share|improve this answer
They work fine. I can brows the internet. – sura2k Dec 1 '11 at 18:41
Can you open mirror.nus.edu.sg/centos in your browser? Are you using any sort of proxy server? – rvs Dec 1 '11 at 18:52
http://mirror.centos.org/centos/6.0/os/i386/repodata/2b014e1fcde80ec1cc69d6a048‌​f260f712b1ae2d83d1fc04d3b3c00ade817ec9-primary.sqlite.bz2 I tried this one on the browser and I couldn't download it manually. I'm not using a proxy server. – sura2k Dec 1 '11 at 19:03

edit your repo setting file at /etc/yum.repos.d/ (there you can find files for each repo that you connect), and uncomment in these files the line that start with #baseurl and comment the line that start with mirrorlist.

share|improve this answer
I did it. Still same – sura2k Dec 2 '11 at 3:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.