Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am reinstalling my Debian system with the Wheezy netinstall image on a USB drive.

I have a wireless router that also comes with ethernet ports, so I could either connect to my LAN via wifi OR ethernet.

The installer was able to detect my wireless (wlan0) and wired (eth0) interfaces, but one of the following always happens:

(1) If I try network autoconfiguration for eth0, the process would always fail at the DHCP autoconfigure step (i.e. can't get IP address?). Please note that this works on the machine, before the re-install I am attempting.

(2) If I try network autoconfiguration for wlan0, it successfully authenticates with my wifi network via WPA2, and configures DHCP successfully. However, I get an error saying there is no "default route" setup. What does "default route" mean?

I have tried to cancel/delete all DHCP leases and restarting my router to no avail. I also tried getting into the shell (which is ash) but there's no ifconfig etc. that I could access.

Can anyone help with troubleshooting this problem? I am eager to reinstall Debian Wheezy soon. Thanks!

share|improve this question
    
What happens if you set a static ip address? After it fails, I think it should give you an option for manual setup. linuxquestions.org/questions/debian-26/… –  user606723 Nov 30 '11 at 22:44
    
A default route indicates where your computer must send network packets whose destination isn't listed in a more specific rule. It's the way to access the Internet as opposed to your LAN. –  Gilles Nov 30 '11 at 23:25
1  
@penyuan It should work automatically, I don't know why it doesn't. If there's a route command, try route -add 0/0 1.2.3.4 where 1.2.3.4 is the IP address of your gateway. –  Gilles Dec 1 '11 at 0:02
1  
@penyuan i had this wheezy problem, this was a bug with a previous netinst, as well. unix.stackexchange.com/questions/25274/… see also bugs.debian.org/cgi-bin/bugreport.cgi?bug=520285 i never actually reported the bug. i had already opted for squeeze and lost the logs. but i will be giving wheezy another go soonish, and if i get it again i will report the bug. fwiw, i installed wheezy on two machines equivalent to the one that was a no go in about october, so if you can dig up the image from october you may have less problems. –  ixtmixilix Dec 1 '11 at 11:11
1  
As far as the squeeze bug was concerned, it was due to binary firmware being unavailable: bugs.debian.org/cgi-bin/bugreport.cgi?bug=558316 Dunno why it would suddenly be a problem with Wheezy netinst but as I said I had the same problem –  ixtmixilix Dec 1 '11 at 11:22
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.