Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is a problem that has persisted in more or less the same state across two different distributions (Debian and Mint), whether as a live boot or after installed to disk.

Essentially, GRUB comes up fine (after choosing a Linux partition/install media), but when I start Linux (either standard or recovery mode) neither monitor receives input. I've tried some solutions I've found via Google-fu (nomodeset, radeon.modeset=0, combining ctrl/alt/f-keys to get a terminal, etc.) but haven't had any success. I could probably try plugging one into the motherboard, but I'd like to be able to use the graphics card so I imagine that'll simply put off the problem. I'd guess it's some kind of issue with the graphics card or its driver, but I can't figure out what to do about that.

Here's some possibly relevant components of my computer - probably the graphics card is the only important part, but just in case:

  • Graphics card: XFX Radeon R7 370
  • CPU: AMD Athlon X4 860K
  • Motherboard: Gigabyte GA-F2A88X-D3H

Other possibly relevant info: I'm going for a Windows/Linux Mint dual-boot on my SSD, with both having access to files on a larger HDD. I installed Windows 10 on this computer first, having heard that installing Linux first would cause Windows' installation to wipe GRUB.

Any and all help will be greatly appreciated.

EDIT: Okay, I'm becoming convinced that there is some really fundamental problem going on here. At school, I've asked graduate students and even one of my instructors for help figuring it out, and they seem fairly perplexed as well. I've tried Ubuntu with no results. Going to remove graphics card and plug monitor into motherboard, see if that works.

EDIT2: Well, I've now determined that my motherboard inexplicably won't provide any kind of video output, even when I've removed the graphics card and enabled integrated graphics in the UEFI. So that's great. Were it not for that, I imagine I could boot into Linux easily, hopefully figuring out what driver/modification/other inexplicable fix I'd need. Seems like every time I install Linux I'm confronted with a conflux of problems which either interfere with basic functionality or the ability to restore that basic functionality. Faulty human perception heuristic, I guess. I'll keep working.

share|improve this question
    
Most likely you have incompatibility issue between packaged ATI Radeon driver and your graphics adapter. Try to force X to use VESA driver instead. If that helps, then try to download and install ATI proprietary Radeon driver. – Serge Jan 25 at 1:59
    
Thanks! I'll give it a go. – sprightlyoaf Jan 25 at 2:17
    
No go. Appended xforcevesa to the linux line, nada. Also tried xforcevesa nomodeset, didn't work either. – sprightlyoaf Jan 25 at 2:25
    
how about both nomodeset and xforcevesa at the same time? – Serge Jan 25 at 2:27
    
Like I said, I tried xforcevesa nomodeset at the end of the linux line. Would I need to try nomodeset xforcevesa? – sprightlyoaf Jan 25 at 2:32

1) Insert your CD linux-mint , reboot your computer and set it to boot from CD in the BIOS and boot into a live session. You can also use a LiveUSB if you have created one in the past.

Install Boot-Repair

  sudo add-apt-repository ppa:yannubuntu/boot-repair
  sudo apt-get update
  sudo apt-get install -y boot-repair && boot-repair

Run Boot-Repair

Click "Recommended Repair".

Now reboot your system. The usual GRUB boot menu should appear.

2)The terminal way

Boot into a live session

open the terminal and enter this command

 sudo grub-install /dev/sdX

X is the drive (letter) on which you want GRUB to write the boot information. for example:

sudo grub-install /dev/sda
share|improve this answer
    
Live boots run into the same problem - no video. I tried unplugging the monitors, plugging one into the motherboard, and trying to enable the motherboard graphics in the UEFI, but it didn't seem to have an effect. Either I did something wrong, or I'll have to pull out the graphics card to get the motherboard to output video and I'd really rather not do that, if possible. – sprightlyoaf Jan 25 at 19:15
    
While system booting menu (Grub) type e to edit the first grub line (Linux Mint ...) add to the linux parameters line 2 flags: nomodeset grub_gfxmode=1280x1024x24 You will boot with a Linux command line. Don't be annoyed by error screens. Keep calm. Just in case (Linux is still maturing) update your system to get last fixes (this is the first run of the recent distribution !). Just do it. apt-get update apt-get upgrade Install ati propietary drivers and reboot. – GAD3R Jan 25 at 19:39
    
All right - I'll give that a try. Thanks for being patient - sorry if I'm being hard to work with. – sprightlyoaf Jan 26 at 12:49
    
Still no go. I've been using the Cinnamon download from here - is there somewhere more updated I should use? – sprightlyoaf Jan 26 at 13:15
    
linux mint 17.3 rosa is the latest and stable – GAD3R Jan 26 at 13:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.