Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to update my nVidia driver but I got an error when I ran the driver installation.

See the error:


  ERROR: You appear to be running an X server; please exit X before            
         installing.  For further details, please see the section INSTALLING   
         THE NVIDIA DRIVER in the README available on the Linux driver         
         download page at www.nvidia.com.


Note: I tried following a guide by typing init 3 but still nothing changed.. How to close the X server?

So I can update the driver

share|improve this question
1  
did you try my service suggestion? – Kevin Nov 29 '11 at 16:57
    
what distro is this? – Patrick Nov 30 '11 at 4:18

Booting to a different runlevel

Runlevels in Linux dictate which services are started and stopped automatically when the system boots or shuts down. The runlevels typically range from 0 to 6, with runlevel 5 typically starting the X window system as part of the services (runlevel 0 is actually a system halt, and 6 is a system reboot). It is good practice to install the NVIDIA Linux Driver while X is not running, and it is a good idea to prevent X from starting on reboot in case there are problems with the installation (otherwise you may find yourself with a broken system that automatically tries to start X, but then hangs during the startup, preventing you from doing the repairs necessary to fix X). Depending on your network setup, runlevels 1, 2 or 3 should be sufficient for installing the Driver. Level 3 typically includes networking services, so if utilities used by the system during installation depend on a remote filesystem, Levels 1 and 2 will be insufficient. If your system typically boots to a console with a command prompt, you should not need to change anything. If your system typically boots to the X window system with a graphical login and desktop, you must both exit X and change your default runlevel.

On most distributions, the default runlevel is stored in the file /etc/inittab, although you may have to consult the guide for your own distribution. The line that indicates the default runlevel appears as

id:n:initdefault:

or similar, where n indicates the number of the runlevel. /etc/inittab must be edited as root. Please read the sections on editing files and root user if you are unfamiliar with this concept. Also, it is recommended that you create a copy of the file prior to editing it, particularly if you are new to Linux text editors, in case you accidentally corrupt the file:

# cp /etc/inittab /etc/inittab.original

The line should be edited such that an appropriate runlevel is the default (1, 2, or 3 on most systems):

id:3:initdefault:

After saving the changes, exit X. After the Driver installation is complete, you may revert the default runlevel to its original state, either by editing the /etc/inittab again or by moving your backup copy back to its original name.

Different distributions provide different ways to exit X. On many systems, the init utility will change the current runlevel. This can be used to change to a runlevel in which X is not running.

init 3

There are other methods by which to exit X. Please consult your distribution.

NVIDIA Accelerated Linux Graphics Driver README and Installation Guide

List all yours processes with:

ps ax

List all your runing services with:

service --status-all | grep +
share|improve this answer

As the error states, you are still running an X server. This error occurs when you try to install the Nvidia .run files while logged in.

Make sure you are logged out.

  • Hit CTRL+ALT+F1 and login using your credentials.
  • kill your current X server session by typing sudo service lightdm stop or sudo stop lightdm
  • Enter runlevel 3 (or 5) by typing sudo init 3 (or sudo init 5) and install your .run file.
  • You might be required to reboot when the installation finishes. If not, run sudo service start lightdm or sudo start lightdm to start your X server again.
share|improve this answer

Depending on your version the way of stopping the X server varies. You have to exit the graphic mode (by typing alt+ctrl+F1, for example), login, and then type one of the following commands to stop the X server:

sudo service lightdm stop

sudo service gdm stop

sudo service kdm stop  //this is the one that worked for mi as I use kdm and Linux mint

Now you can install the drivers and then type

sudo reboot

When you write sudo service press tab to see the options you have (gdm, kdm,...)

share|improve this answer

from my experience i am try this :

  • Alt+F1 then login, sudo telinit 3 (if that isn't work try /sbin/telinit 3), and check that it is changed to level 3 with runlevel that should output something like 5 3 which means that the current run level is 3 and before it was 5.

In case that isn't work, do:

  • ps ax | grep X, and in the output you would see teh PID number of the process X, so you should kill it with sudo kill -9 number where number is the PID number of the process.
share|improve this answer

I don't think I've ever gotten that installing/updating nvidia, but here:

# To stop:
sudo init 3
# To resume:
sudo init 5

Though I'm not 100% sure that'll work on Ubuntu, IIRC they moved away from init. On Ubuntu, try this (replace gdm with kdm/slim/whatever display manager you use):

# To stop:
sudo service gdm stop
# To start:
sudo service gdm start

I'm pretty sure that stops the whole X session

Less cleanly, you could just kill them:

sudo killall /usr/bin/X

But they might respawn.

share|improve this answer
    
I tried your first solution and didn't work, then I tried your second solution it says unrecognised service(I tried all of them) I also tried your last solution and it says no proccess found – Rev3rse Nov 29 '11 at 17:15
    
Under Ubuntu, the basic display manager isn't GDM but LightDM. service lightdm stop. – John WH Smith Nov 3 '14 at 12:54
    
@JohnWHSmith maybe it is now, but it wasn't 3 years ago when I wrote this. – Kevin Nov 3 '14 at 17:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.