Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I tried using cat /proc/driver/nvidia/version but it says the file does not exist.

Is there any alternative way to do that?

I tried to look manually for that file, but I couldn't find it. I also searched for
it and still could not find it.

Any suggestions?

share|improve this question
    
have you tried the command you have post with sudo ? –  Hanan N. Nov 29 '11 at 22:05
1  
@HananN. That file is world-readable on my system, and you wouldn't get a "file does not exist" error if it wasn't –  Michael Mrozek Nov 30 '11 at 0:10
2  
@Rev3rse: are you sure the nvidia module is loaded? Does it appear in lsmod? dmesg|grep -i nvidia? –  Mat Nov 30 '11 at 6:46

4 Answers 4

try nvidia-settings and on the Gui that open you should see the version number.

share|improve this answer

Ok.. first of all, what is this video card and what kernel module is loaded:

$ lspci -k | grep -A 2 -i "VGA"
02:00.0 VGA compatible controller: nVidia Corporation NV41 [GeForce 6800 GS] (rev a2)
  Kernel driver in use: nvidia
  Kernel modules: nvidia, nouveau, nvidiafb
$ _

So I do have nVidia graphics card with loaded kernel module - "nvidia". Let's see more about this driver, but search for the "version":

$ modinfo nvidia | grep version 

Although you could just read a full output if ".. | grep version" returns no result:

$ modinfo nvidia
share|improve this answer
1  
I get no results on my nvidia system –  Michael Mrozek Nov 29 '11 at 18:33
    
Because "could not find module"? Or "| grep version" returned nothing? –  elv Nov 29 '11 at 22:34
    
Grep returned nothing; this is the output of modinfo nvidia on my system –  Michael Mrozek Nov 30 '11 at 0:09

Try to run the nvidia-smi command. It will give you information about your driver version, the cards you have in your system, etc. The advantage is that you do not need a GUI, and it is an altervative to modinfo nvidia.

share|improve this answer
    
Is this actually a solution or a recommendation for the next step in troubleshooting? If the latter, it should be a comment. –  HalosGhost Dec 1 at 16:07
1  
It is nvidia's own management program, which should answer the original question. –  Robert Dec 1 at 16:58

You can also use nvidia-settings from command line:

$ nvidia-settings -q NvidiaDriverVersion

Attribute 'NvidiaDriverVersion' (neptune:0.0): 304.117

Use all to get the whole attribute list (verbose!)

$ nvidia-settings -q all

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.