Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have compiled a kernel with some modules, for example the ath9k for my wireless card. I don't have anything in the autoload configuration (i.e my file /etc/modules.autoload.d/kernel-2.6 is empty). However, lsmod still shows that the module has been loaded. I also notice that when I compile filesystem support as modules (reiserfs, jfs, xfs etc.) they also get autoloaded.

Who is doing this? Can and should I disable it? I am using Gentoo.


share|improve this question
up vote 8 down vote accepted

Udev loads modules automatically depending on what kind of hardware it finds. You can "blacklist" modules in order to stop them being autoloaded as described in the Gentoo udev guide.

share|improve this answer
so, why did the reiserfs, jfs and xfs get loaded too? I don't have any of those? – phunehehe Sep 30 '10 at 11:16
I suppose udev loads those as well to be able to mount (external) harddrives. I'm not on a Gentoo box right now, but you could just try adding the filesystem drivers to the blacklist for modules and see if they stay unloaded. – tante Sep 30 '10 at 11:42
They could also have been loaded by initrd's linuxrc script. – Riccardo Murri Sep 30 '10 at 12:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.