Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Usually when I install Linux on a laptop, I use the following command

$ dd if=installcdrom.iso of=/dev/sdX

where sdX is the inserted, unmounted USB stick (sdb usually), and installcdrom.iso is a CD-ROM image for installing Linux.

That has worked fine many times. The system boots from USB, but 'thinks' its using a CD-ROM. When I boot into the new system, the drive works fine.

But twice now (and last time I simply opted for a different distro, this time I don't have the option to do so), the installation procedure goes fine, everything is great, but when I try to mount media through that port, dmesg tells me that the following happens:

[18080.920173] usb 1-5: new high speed USB device using ehci_hcd and address 5
[18081.053782] usb 1-5: New USB device found, idVendor=058f, idProduct=6335
[18081.053799] usb 1-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[18081.053813] usb 1-5: Product: Mass Storage Device
[18081.053824] usb 1-5: Manufacturer: Generic
[18081.053834] usb 1-5: SerialNumber: 058F63356336
[18081.054232] usb 1-5: configuration #1 chosen from 1 choice
[18081.055566] scsi6 : SCSI emulation for USB Mass Storage devices
[18081.057633] usb-storage: device found at 5
[18081.057644] usb-storage: waiting for device to settle before scanning
[18086.056331] usb-storage: device scan complete
[18086.057068] scsi 6:0:0:0: Direct-Access     Single   Flash Reader     1.00 PQ: 0 ANSI: 0
[18086.664768] sd 6:0:0:0: [sdb] 31291392 512-byte logical blocks: (16.0 GB/14.9 GiB)
[18086.665607] sd 6:0:0:0: [sdb] Write Protect is off
[18086.665621] sd 6:0:0:0: [sdb] Mode Sense: 03 00 00 00
[18086.665630] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[18086.668922] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[18086.668941]  sdb: sdb1
[18086.674627] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[18086.674650] sd 6:0:0:0: [sdb] Attached SCSI removable disk
[18094.767234] UDF-fs: No anchor found
[18094.767246] UDF-fs: Rescanning with blocksize 2048
[18094.824119] UDF-fs: No anchor found
[18094.824127] UDF-fs: No partition found (1)
[18094.941911] ISOFS: Unable to identify CD-ROM format.
[18114.585119] UDF-fs: No anchor found
[18114.585133] UDF-fs: Rescanning with blocksize 2048
[18114.622291] UDF-fs: No anchor found
[18114.622303] UDF-fs: No partition found (1)
[18114.727507] ISOFS: Unable to identify CD-ROM format.
[18116.896705] UDF-fs: No anchor found
[18116.896719] UDF-fs: Rescanning with blocksize 2048
[18116.928426] UDF-fs: No anchor found
[18116.928439] UDF-fs: No partition found (1)
[18117.025404] ISOFS: Unable to identify CD-ROM format.

Everything is fine, SCSI removable disk sdb becomes sdb1, the media is mounted... and... wait, wait... what are you doing? It's not a CD-ROM!

Too late. I get the message that it's wrong fs type, bad superblock, bad option.

Usually this doesn't happen, but it's a problem with the Squeeze installer, I find.

The problem does not appear until the file manager (Dolphin in this case, but I had the same problem with Nautilus last time I used the Squeeze netinst) attempts to mount the drive. Mounting it manually works fine, I'm not going to be the one using this computer, so it needs to mount automatically.

share|improve this question
    
It's not a CD-ROM, but it is in CD-ROM format (which is intended, it uses ISOLINUX to allow this if I recall correctly). Are you sure it was imaged correctly, for example, you are sure that you imaged to the root block device, and not a partition within it? –  Chris Down Nov 25 '11 at 18:44
    
yes. i've never had a problem before except with debian squeeze (in the past year i installed wheezy, lenny, opensuse, and arch, on various machines, all with no problem... this problem, two different machines, there both times, same distro). anyway...i think i've found the answer actually and will post my answer once i confirm... –  ixtmixilix Nov 25 '11 at 20:07
add comment

1 Answer

up vote 1 down vote accepted

It's quite simple in the end... the problem lies with fstab.

there at the bottom of the file was

/dev/sdb1       /media/cdrom0   udf,iso9660 user,noauto     0       0

which of course should be

/dev/sdb1       /media/usb0   auto rw,user,noauto     0       0
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.