Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to install a device. I plug in the device which creates a ttyUSB0 file. When I open it in the program I need it for, it says the permission is denied. I type in terminal

sudo chmod 666 /dev/ttyUSB0

This resolved the problem but after restarting my computer I get the same problem and need to re-enter the same command to get permission. How do I fix this where I dont need to change the permission after every reboot?

share|improve this question
add comment

2 Answers

You can write udev rule to solve this. Google Keywords: udev usb permissions

You can take reference of this and this links.

Create a file /etc/udev/rules.d/51-my_usb_device (for instance). And put the following line:

SUBSYSTEMS=="usb", ATTRS{idVendor}=="10c4", ATTRS{idProduct}=="ea60", GROUP="users", MODE="0666"

Where HEX1 and HEX2 are replaced with the vendor and product id respectively. You can get vendor and product id from lsusb -vvv command.

share|improve this answer
    
thanks a lot ill try this when i get home and post the results :) –  Eugene G Nov 24 '11 at 16:42
add comment

in case you need to change (like me) ttyACM0 permissions, this are my settings:

KERNEL=="ttyACM0", MODE="0777"

It failed when I tried to specify the vendor and product id. I am not sure why.

If you want to restart udev without restarting the machine do this: (Redhat, EL6, Fedora)

udevadm control --reload-rules
start_udev

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.