Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When trying to install FreeBSD 8 off a USB Drive (UNetBootin loaded) I receive

BTX Halted

when choosing any of the Boot options.

  1. Boot FreeBSD [default]
  2. Boot FreeBSD width ACPI disabled
  3. Boot FreeBSD in Safe Mode
  4. Boot FreeBSD in single user mode
  5. Boot FreeBSD with verbose logging

Here is my system I have 256meg of ram on it, and a Transcend CF 133x 4GB for its drive.

I searched the FreeBSD supported hardware and It says AMD Geode LX is supported..

I have also read a post by someone who suggested:

My solution to the BTX halted was to turn of the BIOS IDE DMA Transfers option in the DeviceOptions menu in the BIOS.

but that also did nothing.

Am I missing something? Any help would be greatly appreciated.


11/24 - I just had luck installed FreeBSD 7.4 .. strange that my hardware is listed as supported in the newer versions yet I cannot load the bootloader... I would still like to be able to use the newest version.

share|improve this question

1 Answer 1

I don't have a strong answer for you, but I do have some suggestions.

Non-Geode-specific versions of this problem are all over the web, and it looks like you've already tried some of the common suggestions:

  • disabling ACPI
  • disabling IDE DMA

I've also seen folks have success with:

  • Change disk geometry in fdisk to match what BIOS sees for the boot drive (this might mean having to make a different USB image?)

It might be a good idea to narrow down the problem by eliminating the USB-specific parts of the boot process. Are you able to boot from another device (for example, a Compact Flash card or SATA drive) with a newer FreeBSD already installed?

The fact that the problem is commonly associated with virtualization is also interesting. That doesn't directly apply in your case, but the breadcrumbs of folks investigating it there could be helpful.

You also mentioned in chat that you'd gotten farther with UnetBootin than you'd gotten otherwise; can you elaborate a bit on that - the failure modes that you encounter when trying other methods?

I assume that you've already checked for a newer BIOS, but thought I'd mention it just in case.

If you're really ambitious, you can do a 'binary walk' of updates to source between 7.4 and the next newer OS that worked (8.0? 8.1?) and see where the problem begins. I used this method to track down a problem booting my Whistle InterJets to a change made between 5.2 and 5.2.1.

share|improve this answer
    
Thanks for your answer. I will update the OP with more information shortly. –  rlemon Dec 9 '11 at 18:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.