Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

On my CentOS 5 workstation I get a few seconds wait after dm-raid45 has been loaded ("Initializing Driver" or something like that).

This seems to be part of the initrd. After that the system boots up.

What is going on during those few seconds and what can I do to avoid this wait-time? I have currently no raid installed.

Update 2011-12-14: Problem is still there - deleted previously described "dead" ends from my question.

I hunted down the source of the message to these lines in the init script located in the initrd:

echo Waiting for driver initialization.
stabilized --hash --interval 1000 /proc/scsi/scsi
mkblkdevs
echo Scanning and configuring dmraid supported devices

So stabilized seems to be the line causing the delay. What the heck is that? I did not find any man-page for this and no binary with that name.

share|improve this question
    
This seems to be a bug introduced in Red Hat 5.4??? My current version is 5.7! –  Nils Dec 14 '11 at 20:48

3 Answers 3

up vote 2 down vote accepted

stabilize might take too long due to the --interval 1000 parameter (1000 indicates that there would be 10 checks performed with 1000ms (1s) intervals, which adds up to 9s). From what I've read here, it is a builtin command of nash. This long interval value looks like a workaround for hardware initialization issues described in the above mentioned bug. Try to change the value to 250 and see if your system boots properly.

share|improve this answer
    
Sounds like a good hint. Any idea on how to lower that value with the mkinitrd-command? This seems to be SCSI-related - I have got SATA... BTW - have you got a link describing this "stabilize"-nash-option? –  Nils Dec 22 '11 at 22:18
    
I just found a Stack-Exchange question regarding this. They recommend to modify the mkinitrd script. –  Nils Dec 22 '11 at 22:33

After some research I have done, I found a forum thread at the Centos forums, the user there is complaining the same as you, but it seems that there isn't any easy solution to it.

What I can come up with, is to check that your disks were never part of a RAID system before, and if so remove those remains, and check with fdisk that you don't have any fd partition symbols, because that partition symbol (fd) is for raid system and it could trigger dm-raid to initialize itself.

share|improve this answer
    
Sadly this track was a dead end. I fixed that issue and disabled dm-raid45, but I still got that pause during boot (after the "normal" dm-kernel-modules load). –  Nils Nov 29 '11 at 21:50

Try comment 60 from RH Bugzilla 466607.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.