Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When trying to install something from AUR like I have done successful before with no issues, it now always fails.

[seth@archbang google-talkplugin-amd64]$ makepkg -si
==> Making package: google-talkplugin-amd64 2.5.6.0-1 (Mon Nov 21 19:26:58 MST 2011)
==> Checking runtime dependencies...
==> Installing missing dependencies...
error: target not found: error:
==> ERROR: 'pacman' failed to install missing dependencies.

I don't understand how to fix this error. It does this on others also when it was working.

ADDED:

pacman.conf

#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
HoldPkg     = pacman glibc
# If upgrades are available for these packages they will be asked for first
SyncFirst   = pacman
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#XferCommand = /usr/bin/curl -C - %u > %o
#CleanMethod = KeepInstalled
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options (all disabled by default)
#UseSyslog
ShowSize
#UseDelta
TotalDownload
ILoveCandy

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
## Add your preferred servers here, they will be used first
#Include = /etc/pacman.d/mirrorlist

[core]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

[extra]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

#[community-testing]
## Add your preferred servers here, they will be used first
#Include = /etc/pacman.d/mirrorlist

[multilib]
## Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

[community]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#Server = file:///home/custompkgs

MORE INFO:

[seth@archbang google-talkplugin-amd64]$ sudo makepkg --check --asroot
==> Making package: google-talkplugin-amd64 2.5.6.0-1 (Mon Nov 21 21:31:50 MST 2011)
==> Checking runtime dependencies...
==> Missing Dependencies:
  -> lib32-alsa-lib
  -> libstdc++5
  -> glew
  -> lib32-libxt
  -> lib32-openssl
  -> lib32-libxfixes
  -> lib32-gtk2
  -> lib32-gdk-pixbuf2
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.

MAKEPGK.conf

#
# /etc/makepkg.conf
#

#########################################################################
# SOURCE ACQUISITION
#########################################################################
#
#-- The download utilities that makepkg should use to acquire sources
#  Format: 'protocol::agent'
DLAGENTS=('ftp::/usr/bin/wget -c --passive-ftp -t 3 --waitretry=3 -O %o %u'
          'http::/usr/bin/wget -c -t 3 --waitretry=3 -O %o %u'
          'https::/usr/bin/wget -c -t 3 --waitretry=3 --no-check-certificate -O %o %u'
          'rsync::/usr/bin/rsync -z %u %o'
          'scp::/usr/bin/scp -C %u %o')

# Other common tools:
# /usr/bin/snarf
# /usr/bin/lftpget -c
# /usr/bin/curl

#########################################################################
# ARCHITECTURE, COMPILE FLAGS
#########################################################################
#
CARCH="x86_64"
CHOST="x86_64-unknown-linux-gnu"

#-- Exclusive: will only run on x86_64
# -march (or -mcpu) builds exclusively for an architecture
# -mtune optimizes for an architecture, but builds for whole processor family
CFLAGS="-march=amdfam10 -mtune=amdfam10 -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2"
CXXFLAGS="-march=amdfam10 -mtune=amdfam10 -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2"
LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro,--hash-style=gnu"
#-- Make Flags: change this for DistCC/SMP systems
#MAKEFLAGS="-j5"

#########################################################################
# BUILD ENVIRONMENT
#########################################################################
#
# Defaults: BUILDENV=(fakeroot !distcc color !ccache check)
#  A negated environment option will do the opposite of the comments below.
#
#-- fakeroot: Allow building packages as a non-root user
#-- distcc:   Use the Distributed C/C++/ObjC compiler
#-- color:    Colorize output messages
#-- ccache:   Use ccache to cache compilation
#-- check:    Run the check() function if present in the PKGBUILD
#
BUILDENV=(fakeroot !distcc color !ccache check)
#
#-- If using DistCC, your MAKEFLAGS will also need modification. In addition,
#-- specify a space-delimited list of hosts running in the DistCC cluster.
#DISTCC_HOSTS=""

#########################################################################
# GLOBAL PACKAGE OPTIONS
#   These are default values for the options=() settings
#########################################################################
#
# Default: OPTIONS=(strip docs libtool emptydirs zipman purge)
#  A negated option will do the opposite of the comments below.
#
#-- strip:     Strip symbols from binaries/libraries
#-- docs:      Save doc directories specified by DOC_DIRS
#-- libtool:   Leave libtool (.la) files in packages
#-- emptydirs: Leave empty directories in packages
#-- zipman:    Compress manual (man and info) pages in MAN_DIRS with gzip
#-- purge:     Remove files specified by PURGE_TARGETS
#
OPTIONS=(strip docs libtool emptydirs zipman purge)

#-- File integrity checks to use. Valid: md5, sha1, sha256, sha384, sha512
INTEGRITY_CHECK=(md5)
#-- Options to be used when stripping binaries. See `man strip' for details.
STRIP_BINARIES="--strip-all"
#-- Options to be used when stripping shared libraries. See `man strip' for details.
STRIP_SHARED="--strip-unneeded"
#-- Options to be used when stripping static libraries. See `man strip' for details.
STRIP_STATIC="--strip-debug"
#-- Manual (man and info) directories to compress (if zipman is specified)
MAN_DIRS=({usr{,/local}{,/share},opt/*}/{man,info})
#-- Doc directories to remove (if !docs is specified)
DOC_DIRS=(usr/{,local/}{,share/}{doc,gtk-doc} opt/*/{doc,gtk-doc})
#-- Files to be removed from all packages (if purge is specified)
PURGE_TARGETS=(usr/{,share}/info/dir .packlist *.pod)

#########################################################################
# PACKAGE OUTPUT
#########################################################################
#
# Default: put built package and cached source in build directory
#
#-- Destination: specify a fixed directory where all packages will be placed
#PKGDEST=/home/packages
#-- Source cache: specify a fixed directory where source files will be cached
#SRCDEST=/home/sources
#-- Source packages: specify a fixed directory where all src packages will be placed
#SRCPKGDEST=/home/srcpackages
#-- Packager: name/email of the person or organization building packages
#PACKAGER="John Doe <john@doe.com>"

#########################################################################
# EXTENSION DEFAULTS
#########################################################################
#
# WARNING: Do NOT modify these variables unless you know what you are
#          doing.
#
PKGEXT='.pkg.tar.xz'
SRCEXT='.src.tar.gz'

# vim: set ft=sh ts=2 sw=2 et:

RESULTS

[seth@archbang ~]$ sudo pacman -Syu && sudo pacman -S base-devel
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 multilib is up to date
 community is up to date
:: Starting full system upgrade...
 there is nothing to do
:: There are 11 members in group base-devel:
:: Repository core
   1) autoconf  2) automake  3) bison  4) fakeroot  5) flex  6) gcc  7) libtool
   8) m4  9) make  10) patch  11) pkg-config

Enter a selection (default=all): 
warning: autoconf-2.68-2 is up to date -- reinstalling
warning: automake-1.11.1-3 is up to date -- reinstalling
warning: bison-2.5-2 is up to date -- reinstalling
warning: fakeroot-1.18.1-1 is up to date -- reinstalling
warning: flex-2.5.35-5 is up to date -- reinstalling
warning: gcc-4.6.2-1 is up to date -- reinstalling
warning: libtool-2.4.2-2 is up to date -- reinstalling
warning: m4-1.4.16-2 is up to date -- reinstalling
warning: make-3.82-4 is up to date -- reinstalling
warning: patch-2.6.1-3 is up to date -- reinstalling
warning: pkg-config-0.26-2 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...

Targets (11): m4-1.4.16-2 [0.16 MB]  autoconf-2.68-2 [0.56 MB]
              automake-1.11.1-3 [0.51 MB]  bison-2.5-2 [0.42 MB]
              fakeroot-1.18.1-1 [0.05 MB]  flex-2.5.35-5 [0.24 MB]
              gcc-4.6.2-1 [17.03 MB]  libtool-2.4.2-2 [0.26 MB]
              make-3.82-4 [0.34 MB]  patch-2.6.1-3 [0.06 MB]
              pkg-config-0.26-2 [0.03 MB]

Total Download Size:    0.00 MB
Total Installed Size:   77.21 MB

Proceed with installation? [Y/n] y
(11/11) checking package integrity                 [----------------------] 100%
(11/11) checking for file conflicts                [----------------------] 100%
( 1/11) upgrading m4                               [----------------------] 100%
( 2/11) upgrading autoconf                         [----------------------] 100%
( 3/11) upgrading automake                         [----------------------] 100%
( 4/11) upgrading bison                            [----------------------] 100%
( 5/11) upgrading fakeroot                         [----------------------] 100%
( 6/11) upgrading flex                             [----------------------] 100%
( 7/11) upgrading gcc                              [----------------------] 100%
( 8/11) upgrading libtool                          [----------------------] 100%
( 9/11) upgrading make                             [----------------------] 100%
(10/11) upgrading patch                            [----------------------] 100%
(11/11) upgrading pkg-config                       [----------------------] 100%
[seth@archbang ~]$ sudo pacman -Qi base-devel
error: package "base-devel" not found
share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Many of the dependencies for this application are 32-bit. In order for pacman to be able to install them, you need to enable the multilib repo in your pacman.conf to successfully build the package.

See the multilib entry on the Arch Wiki.

If that doesn't work, you should try installing one (or more) or the dependencies with pacman -S $pkg to ensure that your pacman database is up-to-date and that you are synching to a current mirror.

As Arch is a rolling release, it is critical that you sync to a current mirror - otherwise this will cause all sorts of issues.

If that works, then I would suggest checking your makepkg.conf for any anomalies.

Update You have to build some of the dependencies by hand: libpng12 and openssl-compatability, eg. I have no idea why makepkg isn't printing out the complete error message: it should read:

==> Making package: google-talkplugin 2.5.6.0-1 (Wed Nov 23 18:58:38 NZDT 2011)
==> Checking runtime dependencies...
==> Installing missing dependencies...
error: target not found: openssl-compatibility
==> ERROR: 'pacman' failed to install missing dependencies.

You could also look at using an AUR helper to automatically install dependencies from the AUR.

share|improve this answer
    
Yes this is already enabled, this happens with packages that have no 32-bit deps –  Seth Hikari Nov 22 '11 at 3:04
1  
I don't understand this 'error: target not found: error:' –  Seth Hikari Nov 22 '11 at 3:04
    
Please update your question with details about how you are trying to build the package. Also, is that the complete error message? You could also try this PKGBUILD to see if you get the same error aur.archlinux.org/packages.php?ID=40056 –  jasonwryan Nov 22 '11 at 3:11
    
I am not sure what more I can give, I extract the tarball, run makepgk as I show up there. And yes that is the exact error I get and the same with that PKGBUILD you posted. The error just says that... error –  Seth Hikari Nov 22 '11 at 4:29
    
I have current mirrors from the Arch Linux Mirror Generator. I have posted pacman.conf and makepkg.conf. Thank you for your extended help on this problem. –  Seth Hikari Nov 23 '11 at 0:19
show 11 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.