Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to put the oauth on my redhat server, but since I got this message :

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/oauth.so' - /usr/lib/php/modules/oauth.so: cannot open shared object file: No such file or directory in Unknown on line 0

Do someone know how to put that file on redhat ? I'm not a Linux expert.

Thank you

share|improve this question

migrated from stackoverflow.com Nov 21 '11 at 4:38

This question came from our site for professional and enthusiast programmers.

Well, where did you put it, if not in the /usr/lib/php/modules/ directory? – mario Nov 21 '11 at 4:33
Btw, it seems there is a pre-packed version for Redhat (no installation woes). rpm.pbone.net/index.php3/stat/4/idpl/16821219/dir/redhat_el_5/… – mario Nov 21 '11 at 4:35
@mario I got no idea where it is... – user1040899 Nov 21 '11 at 4:42
how can I put that library ? cause seems to not existe – user1040899 Nov 21 '11 at 4:44
Please don't speak in riddles. Explain in detail what you've tried. -- Have you installed the RPM? If not, what have you installed? How have you installed the oauth.so module if anything? – mario Nov 21 '11 at 4:49
up vote 1 down vote accepted

You need to find the generated oauth.so file.

To do so run (as superuser):

locate oauth.so

Then copy that complete path into the /etc/php.d/oauth.ini.

Usually it's /usr/lib/php5/20090626/pdo.so

share|improve this answer
This seems good but... how do we use updatedb ? – user1040899 Nov 21 '11 at 5:48
I did under SU : updatedb then a blank space comes, I type : locate oauth.so but nothing happens, if I pres enter there is just a new line I need to do Ctrl+c to exit... – user1040899 Nov 21 '11 at 6:51
updatedb takes a while. Cancelling does not usally lead to results. Use find / -name oauth.so instead. Also takes time. (But if for some reason you won't just look yourself...) – mario Nov 21 '11 at 6:56
Please no more comments. Thanks. – mario Nov 21 '11 at 6:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.