Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to use the Android SDK on Arch Linux 64bit but when I try to run ADB from the correct dirrectory it says the file does not exist, but it is there. On Ubuntu when you have this problem you install ia32-lib but there is none in Arch Linux. Is there something I have to do.

share|improve this question
Have you enabled [multilib]? – jasonwryan Nov 20 '11 at 0:41
No I have not, though if I do, what would I need from it? – Seth Hikari Nov 20 '11 at 1:04
Oh these worked thanks! lib32-libstdc++5 lib32-libx11 lib32-ncurses lib32-zlib lib32-sdl lib32-libxext – Seth Hikari Nov 20 '11 at 1:24
up vote 4 down vote accepted

The “no such file or directory” message is in fact referring to the loader for 32-bit executables, which is needed to execute your 32-bit executable. For a more detailed explanation, see Can't execute some binaries in chroot environment (zsh: Not found). You need to install 32-bit support on your Arch Linux.

Unfortunately, Arch Linux doesn't have a simple way of installing 32-bit support. At the moment, you need to enable the [multilib] repository by adding these lines to pacman.conf:

Include = /etc/pacman.d/mirrorlist

See the Arch64 FAQ and Using 32-bit-applications on Arch64 on the wiki for more details.

share|improve this answer

For me, with a reasonably fresh ArchLinux install (November 2015), I had to uncomment the "multilib" section in my /etc/pacman.conf as @gilles suggests.

Further, I had to use pacman to install the required packages like so:

sudo pacman -S lib32-ncurses lib32-zlib lib32-libstdc++5

After this, adb, fastboot and related development utilities like mksdcard all worked just fine on my 64-bit Intel system.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.