Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

This extension is supposed to make a Unity-like launch bar appear in the Fedora 16 desktop. I installed it from the Fedora repositories, logged out, logged in, and it doesn't appear. gnome-tweak-tool doesn't even list it as installed:

gnome-tweak-tool screenshot

The file listing for gnome-shell-extension-dock is:

/usr/share/glib-2.0/schemas/org.gnome.shell.extensions.dock.gschema.xml
/usr/share/gnome-shell/extensions/dock@gnome-shell-extensions.gnome.org
/usr/share/gnome-shell/extensions/dock@gnome-shell-extensions.gnome.org/extension.js
/usr/share/gnome-shell/extensions/dock@gnome-shell-extensions.gnome.org/metadata.json
/usr/share/gnome-shell/extensions/dock@gnome-shell-extensions.gnome.org/stylesheet.css
share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Latest GNOME 3.2 uses new shell extension syntax so “old” GNOME 3.0 extensions don’t work on Fedora 16 or UBUNTU 11.10 using GNOME 3.2

Even when you copy extension to your

/home/username/.local/share/gnome-shell/extensions

folder extensions are disabled by default.

To enable them you need to use the gsettings command from the terminal.

For example download, extract and copy the noa11y@fpmurphy.com extension to your extensions folder.

Then enable extension with gsettings command:

$ gsettings set org.gnome.shell enabled-extensions "['noa11y@fpmurphy.com']"

Source: Installing and enabling GNOME-Shell 3.2 Extensions

So, enable your extension this way:

$ gsettings set org.gnome.shell enabled-extensions "['dock@gnome-shell-extensions.gnome.org']"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.