Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

For some games, I need the nvidia-current driver, but when it's enabled, I can't get my work done as it messes up everything. So is there a way I can get two options in my GRUB menu? One wich will load my operating system with the nvidia-current drivers, and one which will use the default non-proprietary one? It seems a bit stupid to me to have 2 Ubuntu installations (one for games, one for the rest). But I can't get my daily work done with the Nvidia drivers enabled as it messes up some applications, randomly freezes the system, etc. But I still want to be able to play some games.

If there's a way to just load and unload the nvidia-current driver with a script or something, that would also be welcome.

share|improve this question

migrated from askubuntu.com Nov 15 '11 at 22:31

This question came from our site for Ubuntu users and developers.

1 Answer 1

You can prevent the nvidia driver from loading automatically be appending modprobe.blacklist=nvidia-current to your kernel line. If that does not help, try nvidia instead of nvidia-current.

Other than hard-coding the new kernel options for each kernel version, edit /etc/grub.d/10_linux and find the next line:

  linux_entry "${OS}" "${version}" false \
      "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_EXTRA} ${GRUB_CMDLINE_LINUX_DEFAULT}" \
      quiet

Duplicate it and modify it to add the modprobe options:

  linux_entry "${OS} (no nvidia)" "${version}" false \
      "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_EXTRA} ${GRUB_CMDLINE_LINUX_DEFAULT}" \
      quiet modprobe.blacklist=nvidia-current

Run sudo update-grub afterwards to generate the new boot configuration.

share|improve this answer
    
And will blacklisting the driver automatically enable the other one? –  RobinJ Nov 13 '11 at 10:40
    
Do you mean nouveau? –  Lekensteyn Nov 13 '11 at 10:40
    
I guess so... robin@robin-Latitude-D620:~$ lsmod | grep nouveau | pastebinit http://pastebin.com/KxqT6vv7 –  RobinJ Nov 13 '11 at 10:47
    
Hello? Still there? –  RobinJ Nov 15 '11 at 18:19
    
Yes, I thought you've already sorted it out. Did it work as expected? –  Lekensteyn Nov 16 '11 at 14:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.