Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I want to turn off smooth scrolling in KDE4 applications. By smooth scrolling, I mean the visual effect that causes the contents of a scrollable area to shift a bit at a time when I scroll with PageUp/PageDown: I want the transition between one page and the previous/next to be instantaneous.

I'm running KDE 4.4.5 on Debian right this minute and my test application is the help browser, but I'd prefer a method that works accross all versions on all systems. I didn't find anything in the System Settings application (of course, there are a lot of them, so I might just not have found the right tab). I switched Appearance/Style/Fine_Tuning/Graphical_effects to “high display resolution and low CPU” but it didn't help. If smooth scrolling is part of some other larger collection of visual effects that I'd have to turn off all at once, I probably won't mind.

share|improve this question
    
It seems to differ from one widget to another, and perhaps may be specific to the help browser. I see the smooth scrolling when I open the help browser, but not in Kate, Dolphin, or Okular (and I'm pretty sure I haven't configured it away). –  David Z Nov 14 '11 at 23:46
add comment

1 Answer

up vote 1 down vote accepted

Smooth scrolling is a feature of the Qt widget set, not of KDE. There's no system-wide setting that turns it on or off, and disabling it requires changing the problem code. Sorry.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.