Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

According to this writeup ufs kernel module is compiled with only read permissions. I could mount a ufs partition with this command:

sudo mount -t ufs -r -o ufstype=ufs2 /dev/mapper/loop0p1 /mnt/freebsd/

And it mounts the filesystem without write permissions. There is a ufs-utils package for Debian/Ubuntu but I could not figure out how to use it. So there any way to get read/write permissions work for ufs on Ubuntu/Linux.

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

I believe Debian and Ubuntu leave out write support for UFS when they compile their kernel, because the write support in the Linux UFS driver is not considered fully reliable. Rather than expose you to data loss if you mount a filesystem read-write, they prefer to warn you away.

If you want to use the Linux UFS driver for writing, you'll need to recompile a kernel, with read-write support enabled for UFS.

Alternatively, you could run a small installation FreeBSD in a virtual machine (QEMU/KVM, VirtualBox or whatever takes your fancy). Give the virtual machine access to your filesystem image as a raw disk image, mount the filesystem in the VM, and export it over NFS.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.