Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Compiz is "temporarily disabled" by default, I have to enable Compiz by pressing Alt+Shift+F12 every time I start my computer.

Can somebody please tell me how it can be enabled automatically at startup?

I am using Compiz Fusion on Kubuntu 10.10.

share|improve this question
    
Compiz? You mean the Desktop Effects provided with KDE4 right ? –  warl0ck Sep 18 '12 at 1:48
add comment

2 Answers

up vote 1 down vote accepted

You can add compiz --replace line in your ~/.bashrc file, if you want to start it automatically on every login.

share|improve this answer
add comment

Are you using the ATI proprietary (fglrx) drivers? They seem to have problems with compositing when the system is under high load. Such as when KDE is starting up.

If you really want to force compositing to come on at startup, then go "System Settings" > "Desktop Effects" > "Advanced" > "Disable functionality checks". Note that this could make your system unusable if there's a driver problem, and KDE can't disable compositing to work around it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.