Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I upgraded glibc for a reason that isn't arround anymore so i want to downgrade it again. The stupid thing is a lot of programms rely on glibc at the moment. I still have the 2.4 version on the system as the command below shows, but i'm not able to delete the 2.9 version.

# rpm -qa|grep  glibc
glibc-32bit-2.4-31.74.1
glibc-locale-2.4-31.74.1
glibc-locale-32bit-2.4-31.74.1
glibc-info-2.4-31.74.1
glibc-devel-2.4-31.74.1
glibc-2.9-2.9
glibc-i18ndata-2.4-31.74.1
glibc-devel-32bit-2.4-31.74.1

I've tried rpm -e glibc-2.9-2.9 but the system just tells me that a huge amount of stuff depends on glibc. So I was wondering if i can somehow set the 2.4 version to default or so and then remove the 2.9 version.

thanks in advance almightybob

share|improve this question
    
What's wrong with having it? –  Maxim Yegorushkin Oct 6 '11 at 10:34
    
since i did the upgrade my yast doesn't work anymore. I receive this error : warning: the qt frontend is installed but does not work warning: the ncurses frontend is installed but does not work You need to install yast2-ncurses to use the YaST2 text mode interface –  almightyBob Oct 6 '11 at 11:16
    
plus now i think it has something to do with this other problem i'm having stackoverflow.com/questions/7675725/… –  almightyBob Oct 6 '11 at 14:25
add comment

migrated from stackoverflow.com Nov 10 '11 at 11:06

This question came from our site for professional and enthusiast programmers.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.