Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I recently switched to using KDE 4, and I don't like that KDE uses so many of the Ctrl-Fn shortcut keys, since I use them for other purposes. Specifically, I'd like to disable the Ctrl-F4 shortcut in KDE. However, I have not been able to find this shortcut in System Settings -> Shortcuts and Gestures.

UPDATE: Another shortcut I'd like to redefine is the "Show window menu" shortcut, which I like on Alt-Space, but which KDE has on Alt-F3.

I have not been able to find a global place to change all shortcuts.

share|improve this question

3 Answers 3

up vote 3 down vote accepted

All of the global keyboard shortcuts are in "Settings -> System Settings -> Shortcuts and Gestures -> Global Keyboard Shortcuts". You'll probably need to go through each of the KDE components to find and remove the shortcuts you don't want.

share|improve this answer
    
Very nice! I somehow managed to overlook the KDE Component dropdown list. –  daniel kullmann Nov 14 '11 at 7:52

You can configure the shortcuts via this menu path:

Configure Desktop
> Global Keyboard Shortcuts
 > KDE component
  > KWin
   > Window Operations Menu
share|improve this answer

I just found the solution to the Ctrl-F4 problem: The Ctrl-F4 shortcut switches to a different virtual desktop, so I have to right-click on the pager in the taskbar, select Pager Settings -> Virtual Desktops -> Switching. There I can define the shortcuts...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.