Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've started using the Gnome 3 packages that just came through the Debian testing repositories, and encountered a problem.

Hitting the Super/Meta/Windows key would not open "Activities" menu. Other shortcuts (like Alt+Tab, etc.) work as expected.

Can you help me find the reason (and a solution)?

share|improve this question
add comment

2 Answers

Wild guess: Could you have remapped it? That is, does it show up as Super_L (or possibly Super_R) when you press the key with window focus in xev?

Edit: Also check your logs, probably ~/.xsession-errors.

Edit: There are lots of bug reports concerning gnome-shell and Super.

share|improve this answer
    
xev says KeyPress event, serial 32, synthetic NO, window 0x3200001, root 0xb0, subw 0x0, time 192228, (267,145), root:(269,266), state 0x0, keycode 133 (keysym 0xffe7, Meta_L), same_screen YES, XLookupString gives 0 bytes: XmbLookupString gives 0 bytes: XFilterEvent returns: False when I press Super –  Marcel Nov 10 '11 at 21:58
    
oh, ~/.xsession-errors says: Error: Meta_L added to symbol map for multiple modifiers Using Mod4, ignoring Mod1. Error: Key <META> added to map for multiple modifiers Using Mod4, ignoring Mod1. –  Marcel Nov 10 '11 at 22:15
add comment
up vote 1 down vote accepted

Finally I found the reason and a solution:

In Settings > Region and Language > Layouts > Options there is an option "Behaviour of Alt/Windows-Key". For some reason this was not on "Default" per default (hope you get me).

After I put this option to "Default", everything works as expected.

Thank you!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.