Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have no root-acces on a machine and i'm trying to install a library called GiNaC locally in my home folder.

I use this tutorial http://www.ginac.de/tutorial/Configuration.html#Configuration. At the end there is an example (dont need to disable the shared-library and i dont need a specific compiler).

Unfortunatly if I do this

export CPPFLAGS="$(CPPFLAGS) -I$/home/xxx/include"
./configure

this is the result...

...
checking for g++... g++
checking whether the C++ compiler works... no
configure: error: in `/home/redies/ginac-1.6.2':
configure: error: C++ compiler cannot create executables
See `config.log' for more details

In config.log there is the line

CPPFLAGS='CPPFLAGS: command not found -I$/home/xxx/include'

Any ideas?

share|improve this question
add comment

2 Answers

There's an error in that tutorial: in the shell, variable expansions use braces, not parentheses, so you need to write ${CPPFLAGS} and not $(CPPFLAGS). You can leave the braces off, even. Also, if you replace $HOME by its value, the $ must go ($ followed by a variable name means “take the value of”).

export CPPFLAGS="$CPPFLAGS -I/home/xxx/include"

Oh, and if there's no prior value of CPPFLAGS in your environment, you can write this export CPPFLAGS="-I/home/xxx/include" (but it won't hurt to use $CPPFLAGS either, the value is empty if the variable has never been set).

share|improve this answer
add comment

I think that unless you've got extra CPPFLAGS values, this one would work;

CPPFLAGS="-I/home/xxx/include" ./configure

I also think you should run ./configure --help to see if this particular configure-script has command line flags to do what you want. The usual configure-script has piles of options to allow J. Random Non-root-user to install in in $HOME, or whatever.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.