Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed VirtualBox 4.1 on my Windows system, and then added a Solaris 11 Express guest and an Oracle Linux 6.1 guest. Both installs went smoothly. But while the Solaris 11 guest has network access, the Oracle Linux box can't connect to the network.

Both guests are using the same default network settings (NAT). I'm at a loss -- not sure what I need to configure on the OL6.1 side.

To test basic network connectivity, I tried: ping www.google.com. No problems with the Solaris guest. On the OL6.1 guest:

    # ping www.google.com
    ping: unknown host www.google.com
    # ping
    connect: Network is unreachable

Is there some sort of network setup that's required on OL6.1 that wasn't required on Solaris11? Thanks in advance.

output from ifconfig -a:

    # ifconfig -a
    eth0    Link encap:Ethernet  HWaddr  08:00:27:8E:A1:42
            inet6 addr: fe80::a00:27ff:fe8e:a142/64 Scope:Link
            UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
            RX packets:0 errors:0 dropped:0 overruns:0 frame:0
            TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
            collisions:0 txqueuelen:1000
            RX bytes:0 (0.0 b) TX bytes:328 (328.0 b)

    lo      Link encap: Local Loopback
            inet addr:  Mask:255.0.0
            inet6addr: ::1/128 Scope:Host
            UP LOOPBACK RUNNING MTU:16436 Metric:1
            RX packets:0 errors:0 dropped:0 overruns:0 frame:0
            TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
            collisions:0 txqueuelen: 0
            RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
share|improve this question
Please post the output of ifconfig -a. During the installation, did you leave the IPv4 settings on the automatic method (step 10 in the instructions)? – Gilles Nov 4 '11 at 22:40
During installation, I was never given the option to configure the network (step 10 in your instructions). I'm running 6.1; maybe I should go back and try 6.0? – Suzanne Nov 4 '11 at 22:53
up vote 5 down vote accepted

Given that Oracle Linux is heavily based on Red Hat Enterprise Linux, the network configuration is probably the same. If you didn't need to enter any network parameters during the installation of Solaris, then you're picking up a network address through DHCP. There isn't much call for doing anything else in a NATted virtual machine anyway.

To configure a DHCP client on RHEL, edit the file /etc/sysconfig/network-scripts/ifcfg-eth0 to contain the following lines:


Or you can use Network Manager instead (it'll give you the same kind of network configuration through a desktop icon that Solaris has, and in fact I believe it is more powerful than Solaris's — not that you really need that in a VM).

share|improve this answer
Thanks! This solved it. – Suzanne Nov 4 '11 at 23:33

Probably the specified default router might be incorrect. To find out, do

 netstat -r

to see the routing table. Locate the default route (destination, and then ping the default router...i.e.

share|improve this answer
on the OL6.1 guest, netstat -r just displays the header as output; no entries in the routing tables. On the Solaris guest, netstat -r displays info about the default router. – Suzanne Nov 4 '11 at 22:48
Unlikely (and that's confirmed by the ifconfig output). On simple setups, it's rare that the routing is wrong; here, as usual, the issue is that there's no IP connectivity at all. – Gilles Nov 4 '11 at 23:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.