Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I run sudo zypper update:

Overall download size: 134.1 MiB. After the operation, additional 5.7 MiB will be used.
Continue? [y/n/?] (y): y
Automatically agreeing with java-1_6_0-sun-devel package license.
Automatically agreeing with java-1_6_0-sun package license.
Automatically agreeing with java-1_6_0-sun-plugin package license.
Retrieving package libbluray0-0+20111019-1.1.x86_64 (1/54), 60.0 KiB (159.0 KiB unpacked)
Retrieving: libbluray0-0+20111019-1.1.x86_64.rpm [done]
Retrieving package MPlayer-1.0rc4_r34240-2.1.x86_64 (2/54), 17.9 MiB (49.1 MiB unpacked)
Retrieving: MPlayer-1.0rc4_r34240-2.1.x86_64.rpm [done (1.9 MiB/s)]
Retrieving package libcurl4-7.22.0-59.2.x86_64 (3/54), 174.0 KiB (434.0 KiB unpacked)
Retrieving: libcurl4-7.22.0-59.2.x86_64.rpm [done (0 B/s)]
Digest verification failed for libcurl4-7.22.0-59.2.x86_64.rpm. Expected f065534feb71adf943a5e4f86c2bdb4fd930ee36b8ca8b672062f65510f66584, found d9b8e0ac120e1870d6988aa1157190bfd39225fe24aa24e3ab79a60efd3aa6ae. Continue? [yes/no] (no): yes
Package libcurl4-7.22.0-59.2 seems to be corrupted during transfer. Do you want to retry retrieval?
Abort, retry, ignore? [a/r/i] (a): i

I haven't changed anything in my repos recently so I don't know why curl isn't cooperating. What does this error mean? And where does the problem lie?

SOLVED

I ended up having to run sudo zypper refresh before re-trying my update. Thanks to rozcietrzewiacz for hinting to it.

share|improve this question
    
I understand that you are using openSUSE - right? Please don't forget to mention the distribution in the future. –  rozcietrzewiacz Nov 4 '11 at 16:25
    
@rozcietrzewiacz: My bad, thanks for the edit. –  MaxMackie Nov 4 '11 at 17:29

1 Answer 1

up vote 2 down vote accepted

The problem might origin from various places. What it means? Just as the message says: a downloaded file does not match its recorded checksum. Re-fetch the file and it should be OK (just press r to retry). Otherwise report it as a bug or try syncing/updating a bit later.

share|improve this answer
    
It's been happening for 3 days, and I've 'retried' a couple times now. Is this just a waiting game? –  MaxMackie Nov 4 '11 at 15:44
    
Have you tried deleting the downloaded file libcurl4-7.22.0-59.2.x86_64.rpm before attempting an update? –  rozcietrzewiacz Nov 4 '11 at 16:19
    
Also, I can see that "zypper" has a refresh command. Did you use it recently, with all your repositories? –  rozcietrzewiacz Nov 4 '11 at 16:22
    
How would I go about removing the downloaded file? (something along the lines of rpm -e libcurl4-7.22.0-59.2.x86_64.rpm ?). And no, I haven't refreshed recently. –  MaxMackie Nov 4 '11 at 17:29
1  
But the most important thing you should try first is refreshing the repositories! The checksum might have been incorrectly recorded when you last did this. –  rozcietrzewiacz Nov 4 '11 at 23:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.