Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I followed the instructions in the Minix wiki on how to set up Minix in VirtualBox, but right after hitting enter on the boot screen, I get a kernel panic:

*** kernel messages:
ested 0
...
kernel panic: cause_sig: sig manager 2 gets lethal signal 11 for itself
...

I'm using VirtualBox 4.1.2 on Ubuntu 11.10. Am I doing anything wrong? How do I convince Minix to boot?

share|improve this question
add comment

1 Answer 1

up vote 4 down vote accepted

If your hardware supports virtualization, make sure it's activated in the BIOS (some computers have the feature but ship with it disabled). Then make sure that “Enable VT-x/AMD-V” is checked in the “System → Acceleration” tab of the VM settings.

If that's not a solution for you, from VirtualBox 4.0, instead of booting Minix by hitting the Start button in VirtualBox, use this command to start the VM:

VBoxSDL --startvm "Minix 3" --norawr0 --norawr3

(where "Minix 3" is the name of the virtual machine)

The option --norawr0, possibly combined with --norawr3, can help with other guest operating systems such as OpenBSD, NetBSD, QNX

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.