Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have done lots of things to update.

  1. yum clean all
  2. yum clean metadata
  3. yum clean dbcache

then yum update outputs:

http://mirror.centos.org/centos/5.6/addons/i386/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found Trying other mirror.

Error: Cannot retrieve repository metadata (repomd.xml) for repository: addons. Please verify its path and try again

I have also tried

  • setting enabled=0 in /etc/yum.repos.d/CentOS-Media.repo
  • yum -v update --disablerepo=contrib uname -a
  • touch /.autorelabel
  • yum -v update --disablerepo=contrib

but it didn't help.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Go to the URL in a browser and remove path components from the end and you'll eventually find this: http://mirror.centos.org/centos/5.6/readme, which explains why it's not working. Have you modified your CentOS-Base.repo file earlier?

Update to the latest centos-release RPM manually, eg:

rpm -Uvh http://mirror.centos.org/centos/5/os/i386/CentOS/centos-release-5-7.el5.centos.i386.rpm 

And make sure that the CentOS-Base.repo file from it is used and you should have better luck with yum afterwards.

share|improve this answer
    
thanks for your help.. –  Robel sharma Nov 4 '11 at 3:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.