Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have successfully built both libfreenect (driver for Xbox Kinect) and libusb (which is a dependency).

However, if I try to open the Kinect using the freenect_init(...) function, it returns -99.

I tracked down the error to the funtion libusb_init(...) which is returning this error, LIBUSB_ERROR_OTHER.

As I use a minified custom kernel configuration (version: 2.6.37) I think I missed to enable an important config option. Kernel config is available on pastebin.com.

The Kinect gets successfully recognized (reported in dmesg including correct product/vendor information).

Does anyone has an idea how to get rid of this error?

UPDATE: After setting the LIBUSB_DEBUG environment variable to 3 I got the following message: [op_init] could not find usbfs

share|improve this question
    
Did you try with a "normal" kernel? If it works there, something is wrong with your config, and you need to find out what. –  Mat Nov 1 '11 at 8:32
    
Unfortunately there isnt enough space available to have a much bigger kernel. –  SecStone Nov 1 '11 at 8:36
    
Paste your config to pastebin, otherwise there is little to talk about... –  rozcietrzewiacz Nov 1 '11 at 21:04
    
@rozcietrzewiacz: Thanks, I added the link to the question. –  SecStone Nov 2 '11 at 20:56

1 Answer 1

up vote 0 down vote accepted

libusb requires that the VFS usbfs is mounted. After adding the following line to /etc/fstab the problem was solved:

usbfs   /proc/bus/usb   usbfs   defaults   0   0
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.