Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using Arch Linux on a Thinkpad machine. Everything was satisfactory but today I restarted my router and the machine doesn't connect. The router is fine (another machine and a cell phone connect to it easily).

I'm using wicd from a terminal and all I get is a "not connected" message.

How can I fix/diagnose this?

Edit

I tried this without the script and replaced dhclient with dhcpcd (open network) and all I get is a connection time out.

share|improve this question
    
I find wicd gets messed up sometimes. Try restarting wicd: sudo /etc/rc.d/wicd restart. –  Shawn J. Goff Oct 29 '11 at 13:37
    
wicd has a log: to assist with diagnosis, see if there is any detail around the connection failing printed there... –  jasonwryan Oct 29 '11 at 18:34
    
What kind of connection is it, WEP, WPA? Have you tried using the netcfg scripts? –  gregnotcraig Nov 14 '11 at 5:09
    
dmesg is also very talkative when it's about wireless errors. –  Wieland Jan 13 '12 at 19:10
    
What security settings are you using for your connection? WEP? WPA? WPA2? Have you tried turning these off to make sure it's an issue with wicd? –  Joseph Kern May 12 '12 at 16:43
add comment

3 Answers 3

Try checking that there is no dhcpcd stuck with a sudo dhcpcd -k. I get not connected errors when I first use my Android phone w/ tethering (for which I just run sudo dhcpd by hand) and then trying to use wifi .

share|improve this answer
    
Do you mean sudo dhcpcd? –  l0b0 Oct 16 '13 at 20:44
add comment

I have used wicd on Arch in the past. I stopped using it due to issues like this. Try with NetworkManager/dhclient.

share|improve this answer
add comment

I have my Arch linux laptop get connected via a shell script. This is for one of the WEP (I know, I know...) routers I use:

#!/bin/bash

DEV=$(iw dev | awk '/Interface/ {interf=$2} END {print interf}')
PIDFILE=/var/run/dhcpcd-$DEV.pid


if [[ -f $PIDFILE ]] && kill -0 $(cat /var/run/dhcpcd-$DEV.pid)
then
        dhcpcd -k $DEV
fi

ifconfig $DEV down
sleep 1
iwconfig $DEV mode managed
ifconfig $DEV up
iwconfig $DEV channel 1
iwconfig $DEV  key 4567ABCDEF
iwconfig $DEV essid 'ACTIONTEC'
iwconfig $DEV ap 00:0d:51:BF:FE:E1

sleep 5
dhcpcd --noarp $DEV

Every step does just one thing, so it's easy to figure out where the problem lies. The laptop used to run Slackware, under which I wrote the script, but it seems to work just fine under Arch as well.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.