Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm running CentOS 5.7 x86 on my Vostro 1700 laptop which has an Intel Pro Wireless WiFi NIC (Intel Pro Wireless 3945 [iwl3945]).

I'm a bit confused about how my Wireless connection (wlan0) is being managed and where the configuration is being stored.

I initially configured wlan0 via Gnome's Wireless Device Configuration application (System -> Network):

enter image description here

I configured a static IP address if 172.16.3.22 and so on:

enter image description here

I then configured the Wireless Settings to set my SSID etc:

enter image description here

Having done that I then restarted the interface with:

ifdown wlan0
ifup wlan0

So far so good and ifconfig reported that the interface was up.

However when I tried to ping anything on my network the ping failed. It was then I noticed that the Wireless Configuration page didn't ask me about the Wireless security type I was running (WPA2-PSK) - the only options were None, Open system (open) or Shared key (restricted) so it seemed that I wasn't authenticating to my WiFi AP.

I then found another network configuration tool called "Network Connections" under System -> Preferences -> More Preferences. Using this tool I had to add a new connection and it allowed me to configure my Wireless NIC and specify the security type:

enter image description here

I also configured a different IP address of 172.16.3.23 mostly out of curiosity to see if this GUI was configuring the same settings as the previous dialogues and saving these values in /etc/sysconfig/network-scripts/ifcfg-wlan0. However this seems to be a completely different configuration system from what I'm familiar with because ifcfg-wlan0 appears not to be used to save the above config.

To cut a long story short I also had a Google around and discovered that I also needed to start the NetworkManager daemon which adds an icon to Gnome to allow me to enable and disable Networking, Wireless and permits me to choose which AP to connect to etc.

So I'm now somewhat confused as to how my WiFi network is actually configured and where these settings are really stored.

I also notice that when I quit Gnome and drop back to console mode my wireless connection is disconnected wlan0 loses its IP address and appears to be no longer connected.

Whilst I'm very happy I can connect to my WiFi network (by starting Gnome), I'm not happy that I don't understand what's happening under the bonnet.

Can someone explain what is happening with all these different settings?

Also how do I start my wireless connection before starting Gnome?

share|improve this question

3 Answers 3

NetworkManager is controlling the network devices while in Gnome. To view the settings related to NetworkManager check out the files in: /etc/NetworkManager/ /etc/NetworkManager/system-connections/

Additionally, some secure settings (WPA, etc) must be in a secure container (Seahorse) to be supplied to your connection manager (wpa_supplicant on the command line or NetworkManager within the GUI).

share|improve this answer

Explanation.

As was already mentioned, Network Manager is managing your wlan0 interface, ONLY while the user, who configured it, is logged on in GNOME. Otherwise the interface is down. That's why you can not reach your network.

Solution.

To have the interface up and running while GNOME is not started, you need to configure the interface in /etc/network/interfaces. The interface will then be started, when the system is started.

Here is a sample configuration I use on one of my computers:

auto wlan0

# remove dhcp if you want to manually configure the interface
iface wlan0 inet dhcp
    wpa-ssid <YOUR_SSID_HERE>
    wpa-psk <YOUR_PASSWORD_HERE>

#   uncomment the following lines to manually configure the interface
#   address 192.168.1.3     
#   netmask 255.255.255.0
#   gateway 192.168.1.1

See man interfaces for details on this configuration file.

Trade-offs.

The only disadvantage the solution has is that you won't be able to configure the interface using Network Manager, while there are entries for this interface in /etc/network/interfaces. So if you really need to switch back to Network Manager, you will need to comment out couple lines in /etc/network/interfaces and restart the interface.

Cheers.

share|improve this answer
3  
These directions apply well enough to Debian based systems, but are completely useless for CentOS. –  Michael Hampton Sep 8 '12 at 10:36
2  
Suggesting that people manually edit /etc/network/interfaces by hand for their wifi is not very helpful since it is fraught with peril, not to mention being cumbersome since you have to manually change it every time you move to a new SSID or if you want it to be dynamic you have to set up your supplicant by yourself which is not the simplest thing to get right. Just use NetworkManager and click "Available to all users" and the problem is solved. –  aculich Dec 28 '12 at 9:33
3  
This question is about CentOS, this answer is worthless since none of the files are the same for configuring the network b/w CentOS & Debian. –  slm Jun 8 at 3:06

When you edit the wireless settings you need to make sure that "Available to all users" and "Connect automatically" checkboxes are enabled and it will be available to everyone automatically. Early versions of Network Manager for some systems did not have "Available to all users" enabled by default (yours might be one of those systems) and the symptoms you describe are exactly the behavior that is supposed to happen with configuration setting. That was a confusing default setting for most people, so now the default is to have it enabled (at least it is for Ubuntu).

enter image description here

You can also check from the command line what devices and connections are managed by NetworkManager:

$ nmcli dev
DEVICE     TYPE              STATE        
wlan1      802-11-wireless   connected    
eth1       802-3-ethernet    connected    
$ nmcli con
NAME                      UUID                                   TYPE              TIMESTAMP-REAL                    
Yak n Yeti                b4e05828-e57e-4399-96aa-6cd988ee4975   802-11-wireless   Thu 27 Dec 2012 07:30:19 AM PST   

The settings are stored in /etc/NetworkManager/system-connections/ and you'll want to make sure that autoconnect=true and that either the users you want are listed permissions=user:whoever:root:; or the equivalent of "Available to all users" which is permissions=[];

[connection]
id=Yak n Yeti
uuid=b4e05828-e57e-4399-96aa-6cd988ee4975
type=802-11-wireless
permissions=user:whoever:;
autoconnect=false
timestamp=1355439451

[802-11-wireless]
ssid=Yak n Yeti
mode=infrastructure
mac-address=24:77:05:FF:97:BC
security=802-11-wireless-security

[802-11-wireless-security]
key-mgmt=wpa-psk
wep-key-flags=1
psk-flags=1
leap-password-flags=1

[ipv4]
method=auto

[ipv6]
method=auto
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.