Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I noticed a problem with certain video files where speech volume component is just too low. I googled a bit and it seems that the problem is that it tries to play surround sound on stereo speakers and it fails to blend everything in as it should. If I play the same video in mplayer, everything is normal.

Does anyone else have the same problem? Anyone know how to fix this? I tried changing the output module in vlc audio settings, but the problem would remain no matter what I chose. Thanks.

Version of VLC that I am using is 1.1.12 on Arch-Linux (KDE 4.7.2).
If you any additional info is needed, I will provide it.

share|improve this question
Downmixing/Adjust from 5.1 to 'true' 2.1 bbs.archlinux.org/viewtopic.php?id=133053 Surround sound in Linux: halfgaar.net/surround-sound-in-linux – The Demz Mar 19 '14 at 7:53

Downmixing/Adjust from 5.1 to 'true' 2.1

I use ALSA and Pulse Audio on my Arch Linux machine.

You want to control how downmixing to 2.0 is done, so you're going to define a custom sound device in /etc/asound.conf

You can use this output configuration:

(add the custom function to the file /etc/asound.conf)

  type route
  slave.pcm surround51
  slave.channels 6

  # Front and rear, at 33% of original signal strength
  ttable.0.0 0.33
  ttable.1.1 0.33
  ttable.2.0 0.33
  ttable.3.1 0.33

  # Center channel routing (routed to front-left and front-right),
  # 6dB gaindrop (gain half of main channels) per channel
  ttable.4.0 0.16
  ttable.4.1 0.16

  # LFE channel routing (routed to front-left and front-right),
  # 6dB gaindrop (gain half of main channels) per channel
  ttable.5.0 0.16
  ttable.5.1 0.16

Then in VLC

Go to the audio preferences

Tools -> Preferences -> Audio

Set Outputmodel to Alsa audio output


Set Device to Default ALSA Output (currently PulseAudio Sound Server)

Save and restart VLC

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.