Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am running Linux Mint 11 on my notebook, which is basically a variation of Ubuntu. I have been hearing a popping noise in the speakers ever since I installed the OS, but just now realizing that the popping sound only happens on battery power. This noise is driving me insane and even happens when I mute the speakers. It sounds like: "pop" [30 sec pause] "pop pop". Please someone, anyone help me.

Notebook: HP Pavilion DV6325US P/N: RV004UA OS: Linux Mint 11 (with current updates)

share|improve this question
    
That is a well known phenomenon called pop music. –  taffer Jan 14 '12 at 19:29
add comment

migrated from askubuntu.com Oct 26 '11 at 16:39

This question came from our site for Ubuntu users and developers.

3 Answers

up vote 2 down vote accepted

It might be a side effect of sound chip powersaving (switching on and off). I experienced something similar when I misconfigured tlp (a power management tool), which switched the hda-intel chip off every couple of seconds

I am not sure where to configure similar options without tlp. Might depend on which powermanagement tools are in use.

share|improve this answer
    
Thanks everyone. I installed Linux Mint 12 and the problem is pretty much gone. –  ITman Dec 28 '11 at 20:41
add comment

I believe the problem is probably a quirk in ALSA's config. See here: https://help.ubuntu.com/community/HdaIntelSoundHowto

You will probably need to tweak your config a bit, and the noise should go away. P.S. Try an Ubuntu Live CD if you can. If the problem does not occur there, then you know it's very specific to your installed system.

share|improve this answer
    
I am having a little bit of difficulty getting this correct. I'm following the instructions, but my Codec is not in the list like the examples are. My codec is Conexant CX20549 (Venice). –  ITman Oct 27 '11 at 16:54
    
@ITman: I wouldn't call myself an alsa expert, but that's likely an hda-intel chip masked as something else. I would suggest reporting a bug. –  RolandiXor Oct 27 '11 at 16:59
add comment

I had the same problem in a Hp pavilion dv1000, with Linux Mint 13 LTS (xfce version). It was apparently solved by right clicking the batery icon next to the clock, selecting "Preferences", clicking the "on battery" options and removing the selection from the "... over performance" option (sorry, I'm using Mint's portuguese version and I'm not sure what's the english version of those options).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.