Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

After installing Wine, Notepad has became a default application to open unknown textual files by double click. I'd like to eliminate this behaviour and remove Notepad from the list of applications offered to open an unknown type file. I've deleted /usr/share/applications/wine-notepad.desktop, but this didn't help. How can I disable Notepad correctly?

I use XUbuntu 11.10 (XFCE 4.8) and Wine 1.3.

share|improve this question
add comment

3 Answers 3

up vote 5 down vote accepted

I had that problem too some months ago, and I remember I had to delete some .desktop files that were inside the $HOME/.local/share/applications folder. I think you should delete any file that has notepad as part of its name, and also you should try to delete (or move somewhere else) the files wine-extension-*.

share|improve this answer
add comment

Modify /usr/share/applications/wine-notepad.desktop, adding the line:

Hidden=true

There is a bit more information about what that does here. Alternatively, you could probably just delete that file instead.

share|improve this answer
add comment

You can also follow the instructions here to disable this behavior altogether:

http://wiki.winehq.org/FAQ#head-c847a3ded88bac0e61aae0037fa7dbd4c7ae042a

Although you'll still need to follow the steps in nozimica's answer to get rid of existing associations.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.