Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I plug in SIPOD, my pet ipod, thunar tries to auto-mount two partitions instead of one.

This annoying pop-up is starting to kill me:

alt text

This is what /dev/sde looks like:

$ sudo file -s /dev/sde*
/dev/sde:  x86 boot sector, code offset 0x58, OEM-ID "MSDOS5.0", Bytes/sector 2048, sectors/cluster 8, reserved sectors 512, Media descriptor 0xf8, heads 255, sectors 39075371 (volumes > 32 MB) , FAT (32 bit), sectors/FAT 0, infoSector 0, Backup boot sector 0, reserved3 0x50000, physical drive 0x5, serial number 0xa88b3652, label: "       iPod"
/dev/sde1: data
/dev/sde2: x86 boot sector, code offset 0x3c, OEM-ID "*UOKJIHC" cached by Windows 9M, Bytes/sector 2048, sectors/cluster 8, Media descriptor 0xf8, heads 255, hidden sectors 64260, sectors 39011108 (volumes > 32 MB) , FAT (32 bit), sectors/FAT 9522, reserved3 0x1000000, reserved 0x1, serial number 0x58dd9832, label: "SIPOD      "

Is there a way to tell thunar to completely ignore /dev/sde1?

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

I don't belive that the thunar automount is configurable to ignore special devices (I'm not for 100% sure...).

Anyway in my point of view, mounting filesystems is not the job of an application, it should be the job of the operating system.

You could disable thunars automount feature and use udev and autofs.

With udev rules you can recoginze your devices and define how to handle it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.