Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I just set up a new Arch with Gnome 3.2. Until now, everything seems to work fine, except for the brightness adjustment. When I try to adjust the brightness from within the Gnome settings or with Fn+☼↑, the screen flickers for some seconds and afterwards the brightness stays the same (Fn variant) or has changed (Gnome settings). It seems like some other part of the system insists on keeping the brightness as is, there is a fight and this other part wins.

edit:

The Hardware is a Samsung N130 Netbook with an Intel 945GME graphics controller.

update: The culprit of this manifests itself as this line in /var/log/messages:

samsung_laptop: SABI set command 0x01 failed with completion flag 0xaa and data 0xff

Some research led to this, which says that a patch for the problem is on its way into the 3.2 kernel.

share|improve this question
    
Did you see anything from kernel output ( /var/log/messages for example ) ? Have you tried to load kernel modules like thinkpad_acpi for Thinkpads ? –  warl0ck Nov 2 '11 at 7:21
add comment

3 Answers

You may try the following, this might bring you luck.

  1. Open your terminal (Ctrl+Alt+T)
  2. sudo vi /etc/default/acpi_support
  3. Find and enable this line (remove the # behind):

    ENABLE_LAPTOP_MODE=true

  4. Install the laptop mode tool from Laptop Mode
  5. sudo vi /etc/laptop-mode/laptop-mode.conf
# Enable laptop mode when on AC power.
ENABLE_LAPTOP_MODE_ON_AC=1
# Should laptop mode tools control LCD brightness?
CONTROL_BRIGHTNESS=1
# Commands to execute to set the brightness on your LCD
BATT_BRIGHTNESS_COMMAND="echo 0"
LM_AC_BRIGHTNESS_COMMAND="echo 9"
NOLM_AC_BRIGHTNESS_COMMAND="echo 9"
BRIGHTNESS_OUTPUT=”/sys/class/backlight/acpi_video1/brightness”

You can read the instructions before editing the file:

***********************************
# * If your system has the file “/proc/acpi/video/VID/LCD/brightness” (VID may
# be VID1 or similar), use this file as BRIGHTNESS_OUTPUT, and use
# the command “echo “. The possible values can be listed using the
# command
#
# cat /proc/acpi/video/VID/LCD/brightness
# * If you have a file /sys/class/backlight/…/brightness, then you can use
# that file as BRIGHTNESS_OUTPUT, and the command “echo “.
#
# As far as I understand it the values are between 0 and
# the value contained in the file /sys/class/backlight/…/max_brightness.
**********************************
share|improve this answer
add comment

I've been having the same problem with my Dell Laptop running Xubuntu. The solution offered by Blue Sky hasn't worked for me, but I was able to set up a script (to be run thru sudo).

cd /sys/class/backlight/intel_backlight
cat max_brightness > brightness

There is also a /sys/class/backlight/dell_backlight directory, but that didn't seem to work on my system.

share|improve this answer
add comment

After hacking around for hours and getting to various states of half-working brightness up/down Fn keys I ended up installing samsung-tools - this guide worked for me nicely.

I was able by pressing Fn keys to decrease brightness only. But using terminal I was able to adjust brightness normally - increase/decrease.

Samsung np300v5z, Ubuntu 12.04.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.