Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've recently installed Debian squeeze on a new machine, and decided to try out the default gnome setup rather than attempt to do everything myself.

I added a printer using System > Administration > Printing -- it found my network printer just fine.

However, when powering on the machine this printer is disabled. I have to go to the same dialog as above, enter the root password and enable the printer manually before jobs will be accepted.

Any ideas on how to enable the printer automatically? Note that it's quite possible the printer is turned on after the computer, if this makes a difference. Either way it would be nice if the computer noticed when the printer was turned on.

share|improve this question

Sounds like maybe the cups daemon is not running on start up. That is what it was when I had similar issue. You can check to see if it is running at start up. As root run

# service cups status

if it is not running, then run

# service cups start

See if that changes in the printer dialog.

If that worked, to have cups run at startup

# update-rc.d cups defaults

Just a thought, on my current system the daemon is listed as cups, but; if you try cups and it returns

cups: unrecognized service

you might try

cupsd in place of cups

share|improve this answer
Thanks for your answer Steve. Weirdly, every time I've checked the status of the printer since posting this question, it's been enabled! Maybe that thing where you say to an expert colleague, "Come and look at this error... oh, it seems to work now" :-) – Paul Stephenson Sep 23 '10 at 18:14

I think this is the same problem as here:


Samba comes before Cups, therefore it doesn't know that there are any printers.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.