Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

We got a new printer (HP m1212nf) as it was stated on the hplip site to be supported.

Printer has been tested in windows so we know it works as well as it's network setup.

Current system I am attempting to set this network printer up on is Debian 6 squeeze fully up to date. I downloaded the newest HPLIP from their site. Ran the .run file and followed directions. Installed the prerequisites and ran and hp-check to make sure all was included.

hp-setup was ran where I added the printer. I tried a test page and it came out as raw pdf data. I then followed with a simple few words from gedit. Same thing, pages of rubbish. Tried a PDF file and I got 6 pages of junk(raw pdf).

Not exactly sure what to do in this situation. My system does connect, but it seems the printing is getting distorted someplace. any ideaS?

share|improve this question
    
Assuming you use cups, have you looked at the logs in /var/log/cups/? –  sr_ Oct 22 '11 at 7:49
1  
I've had similar behavior with some HP printers. Try to update the hplip package on your system and then, via CUPS (go to locahlost:631 in browser), re-add the printer with (as a new one). –  rozcietrzewiacz Oct 22 '11 at 13:34
    
Thank you rozcietrzewiacz –  Recursion Oct 23 '11 at 17:48

1 Answer 1

up vote 0 down vote accepted

Almost certain me restarting cups resolved this issue as well as making sure that the printer was in cups config http://127.0.0.1:631/

Thanks all

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.