Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I want to mount a netword drive on the server (SBS2008). I have two options: Either using a fedora which already mounts on a CentOS server or directly on the CentOS server. Here is the command I tried on the fedora machine:

mount -t cifs //192.168.xx.xx/abc /mnt/lan -o username=usernameofwindowsmachine,pass=xyz

If I use this command nothing happens and if I press enter it goes in the next line and make nothing.

I also tried to mount on the CentOS directly but no command worked (mount -t smbfs, smbclient, smbmount, ...). Smbmount is not installed. smbclient gets a timeout and fedora use cifs and not smbfs ... The fedora machine already has a mount on a Windows 2003 Server, but I don't know how this has been made. I don't want to install something because I only want to transfer a big file from CentOS to SBS2008.

Because I'm a beginner I'm missing knowledge in Linux ..

Edit:
So it is not that easy to mount a network drive ... I went another way: I saw that WinSCP was installed on the SBS2008 and connected on the machine and managed to transfer the file. The speed is not that good (1,8 MB/sec.) but hey it works.

share|improve this question
add comment

1 Answer

This must be

     mount -t cifs //192.168.xx.xx/abc /mnt/lan -o username=usernameofwindowsmachine,password=xyz

Anoather approach ist a credentialfile like /root/.cifscredentials

     username=usernameofwindowsmachine
     password=xyz

and then use

     mount -t cifs //192.168.xx.xx/abc /mnt/lan -o credentials=/root/.cifscredentials

Next should be using

     mount -t cifs //WindowsDnsName/abc /mnt/lan -o credentials=/root/.cifscredentials,ip=192.168.xx.xx

Another thing is the Windows Domain Name, which can also be added to the mount options

     mount -t cifs //WindowsDnsName/abc /mnt/lan -o credentials=/root/.cifscredentials,ip=192.168.xx.xx,domain=WinDomainName

After all take a closer look to man mount.cifs

share|improve this answer
    
Thanks for your answer! No matter what I tried I always got the same result (can enter text, go in the next line). How can I see the .cifscredential? It is not shown with ls. –  testing Oct 21 '11 at 13:41
1  
If you use ls -a you should see the file. Because the filename starts with a dot it's hidden. Ich you user cat /root/.cifscredentials you will see the content of the file. –  f4m8 Oct 24 '11 at 6:41
    
Thanks for the information! Do you have an idea why the mount commands you posted do not work? And in /home I see a folder which mounts to a W2k3. How does the mount works there? –  testing Oct 25 '11 at 8:49
    
Some more information about "do not work" (error messages, etc) will help. On older systems the old smb mount is the default. On newer systems actual mount.cifs ist standard. You can check that with 'mount-cifs -V`. –  f4m8 Oct 26 '11 at 8:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.