Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've recently installed syslog-ng but am confused about how to start it (on Fedora).

I do:

/etc/init.d/syslog-ng start 

which reports that it's started ok. However, it doesn't actually do anything until I do:

/sbin/syslog-ng

at which point it starts behaving as I'd expect. Is this expected behaviour?

share|improve this question
add comment

1 Answer

Recent Fedora versions ship with systemd. There you could change to syslog-ng using the following commands:

yum install syslog-ng
systemctl disable rsyslog.service 
systemctl enable syslog-ng.service
systemctl stop rsyslog.service
systemctl start syslog-ng.service

At the end probably also remove rsyslog with rpm -e rsyslog.

share|improve this answer
1  
Does /etc/init.d/syslog-ng exist regardless of syslog-ng being installed or not on Fedora? And it starts the default logger daemon, regardless of script's name? –  rozcietrzewiacz Oct 21 '11 at 11:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.