Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

I finished installing CentOS 6, but when I tried running yum update I got:

[root@centos6test ~]# yum update
Loaded plugins: fastestmirror, refresh-packagekit
Determining fastest mirrors
Could not retrieve mirrorlist
error was 14: PYCURL ERROR 6 - "" Error: Cannot find a valid baseurl for repo: base

Why is that happening? How can I fix it?

share|improve this question

migrated from Oct 19 '11 at 11:11

This question came from our site for professional and enthusiast programmers.

Are you connected to the network? Can you ping –  Nikhil Mulley Dec 4 '11 at 8:51
What happens if you run curl '' ? –  rvs Jan 3 '12 at 9:09

7 Answers 7

First you need to get connected, AFAIK CentOS 6 minimal set your network device to ONBOOT=No, just do a dhclient to your network interface and you should be up and running.

share|improve this answer

Try adding these entries to /etc/resolv.conf:

share|improve this answer

I had the same problem yesterday and I spent hours trying to solve it. The solution ended up being simple.

Delete all the content of 'remi.repo' file and then execute

# yum update

It's done! The file's content will start the download again and be configured.

share|improve this answer
Where is this remi.repo file located? –  user28377 Dec 6 '12 at 11:04
/etc/yum.repos.d/ –  Steven Kryskalla Feb 6 '13 at 20:40
I may have miss something, but where do you see he has the Remi's repo installed ? He clearly mentioned 'I finished installing CentOS6', I kind of doubt Remi's repo are configured. I might be wrong... –  Spredzy May 14 '13 at 22:21

For me I edited the file /etc/yum.repos.d/CentOS-Base.repo and uncommented baseurl.

[base] name=CentOS-$releasever - Base mirrorlist=$releasever&arch=$basearch&repo=os baseurl=$releasever/os/$basearch/ gpgcheck=1 gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6

share|improve this answer

I had the same issue and it got resolved after I edited /etc/yum.conf file. If you are running on proxy server and the IP which is given to the server is bypassed but still when you open in browser (IE - we need to give check mark on proxy but no need to give username and password.)

Add this following line in the main section of the file /etc/yum.conf file.


ie, substituting the proxy address with actual proxy. Also change the port number if it is not 8080.

If proxy requires authentication, add this also to the file

share|improve this answer

Here's yet another possibility that I stumbled upon, causing this problem:

I was using a Puppet module to create the EPEL repo for CentOS, the stahnma/epel module.

Within the module it constructed the repo URL with the variable ::os_maj_version which didn't exist in my list of facts. I had to replace that with ::operatingsystemmajrelease.

So the URL in /etc/yum.repos.d/epel.repo was malformed.

share|improve this answer

I had been struggling with the same problem on Centos6.4 x86_64. I got the following error :

Could not retrieve mirrorlist error was 14: PYCURL ERROR 6 - "Couldn't resolve host ''" Error: Cannot find a valid baseurl for repo: base

So, I fixed it by these steps:

edit network interface. For my case, I used eth0 in CentOS 6.X In CentOS 7 you can use the "ensxxx" interface.

vim /etc/sysconfig/network-scripts/ifcfg-eth0

update NM_CONTROLLED to no


restart the network interface

ifdown eth0
ifup eth0

Hope this help

share|improve this answer
ifcfg-eth0 does not exist on CentOs 7 –  shailenTJ Jan 31 at 18:31
@shailenTJ Just touch it ~ works fine. –  Eddie B Sep 5 at 7:01

protected by Community Oct 14 '14 at 17:21

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?